NTRIP casting. Network setup issues

I’m having issues setting up a base station. It’s working fine through RTK2go but when I try to run the caster directly from my Ip it just doesn’t seem to work. I’ve got port 2101 open on the router and GRC.com shows this port open at my IP when I have a caster running but somehow it just doesn’t work. I may have something fundamentally wrong as I don’t know much about this side of things. Just wondering if anyone can come up with a likely reason.
Tried snip, ESP32-xbee and RPINtripBase. none work directly. Presently sending to RTK2gp with ESP-32Xbee.

Thank you.

In addition to having the port 2101 open at the your router, do you have port forwarding for this port towards the IP address of your caster?

How are you testing direct caster connection? Is the rover connected to public internet or your “home network” along with the caster?

You must have a public IP address at your router. What happens if you point a browser e.g. from your cell phone (not connected to the wlan at home) to port 2101 of your home address (like my.public_home_ip:2101)?

I’ve tried both home network and phone hotspot for the rover. Doesn’t seem to make any difference. I don’t really know what I’m doing with router setup. Basically what I’ve done is this. It’s probably wrong!

The ip being the local ip of the caster.
I have a static broadband IP address.

Pointing a browser at My IP:2101 returns nothing.

router

While waiting for better guidance, have you tested your caster with an NTRIP client running on the caster computer? With SNIP you could try Lance Lefebure’s NTRIP client. You could try another intranet computer too.

Does your caster respond to your browser from home network (192.168.2.109:2101 on a computer in the same network as the caster)?

Well I’ve tried snip itself on two machines and also from wine in linux. The XBee is obviously another machine.

No, no response from a local machine. It’s obviously my lack of knowledge that is the issue.

I’m sure most of us have struggled setting up the caster for the first time.

Looks like your caster is not properly running. I could try to verify your SNIP configuration as I have no experience on the other casters that you have tried. I use the BKG caster on Ubuntu for real (even if I’m not that familiar with either one, Linux or BKG) but I have SNIP caster running too for testing.

Your base must be fine if all works fine through rtk2go. Did you use SNIP to push the RTK correction data to rtk2go? If yes, then your NTRIP server side (or the equivalent) is fine. You can see the SNIP input counter increasing.

SNIP user accounts have been set and the caster IP and port are set (192.168.2.109 and 2101) and the caster has been started or configured to auto-start?

EDIT: I would first try to make an independent NTRIP client work, running on the same computer as the caster. The client does not need to be connected to any GNSS reciver, just receiving correction data from the caster.

I used ESP32 XBee to send data to rtk2go. I’ve now managed to get correction data to go across my local network. Source tables weren’t working because Chrome doesn’t like them. They show up in Firefox at my local network addresses. It seems I just can’t get it out of my router!

1 Like

Please check following things:

Public IP for WAN side (=outside world) on router. (You might have to use a different APN on your router settings for this. Check details from your internet connection provider).

Port forwarding set right on the router.

Firewall open in the pc running the ntrip caster.

Ntrip caster program running and caster IP & Port set right.

Basically all I have done is what is posted above. I have a static IP. and I know what it is No firewall on ESP32 XBee or Raspberry Pi.

I’ve tried to google this but most of the info available is useless.

I’ve tried casters set to own ip adress, my ip adress and localhost. All port 2101. Works on the local network.

My next move is to just ask my isp. They are good and will no doubt know what i’ve got wrong.

No idea what you mean by APN. My router is probably a bit shit too, to be blunt.

Some good advice in this thread.

Sorry, but going back to basics. Is your caster IP static, can you confirm that it is 192.168.2.109.

Your firewall rule is fine, I’m just wondering if the LAN IP of your caster has changed?

1 Like

I need basics! :grimacing:

I don’t know how to make them static on this router. I’ve done it on others I’m sure but this one is not very intuitive. I’m going to scrap it. BUT I have set the router up to the present device IP and it still fails to get to the outside world on every device apart from with RTK2Go which obviously doesn’t require my outside visibility.

I do have a second broadband connection with a different provider and obviously a different router.I haven’t tried this yet because the casters are out of it’s wifi range and it has no ethernet link to my office either. Maybe this might be worth investigating?

Is your caster running Windows or Linux?

Edit: sorry. I’m still new to all of this. I’m assuming you’re running a caster on a laptop, but this is where you tell me that a caster is a base station… is it? And therefore running on neither.

Either way, you have set up your port 2101 to send traffic to 192.168.2.109. You need to make sure your caster has that IP address permanently set.

If that is all done and there are no other firewalls on the caster, then I don’t think the problem is with your network.

ESP32 Xbee so obviously an ESP32 (currently on RTK2Go and seems fine on that) , also a raspberry pi (RPINtripBase) so linux. I’ve tried with snip on a windows 10 laptop too. I’m sure the caster side isn’t the issue. It works on the local network.

I hate windows with a passion so have absolutely no wish to run one on that permanently.

heh, Yep… see my edit. I haven’t got as far as caster yet.

I assume that you can set your IP in the sketch? Or if you have to set this on the R-Pi, then check this:

I’ll check this out thank you.

The ESP32Xbee has a static option but I don’t understand it fully and if you just set it to static without properly setting it up it disappears off the network. Thankfully it has both a hardware default reset and it’s own wifi hotspot for setup.

Setup is done on a web page it produces.

The raspberry pi one is setup using ssh over the network, editing config files.

My preferred option though is the raspberry pi RPINtripBase.

Ok, an update.

I’ve made progress, not least because of your confidence in my network settings.

I am guessing I have had issues with all my casters.

ESP32-XBee is now working from outside my local network. My problem with that was I had got it sendinig to RTK2Go as well as trying to act as a caster itself. With both enabled, server and caster, the server still works fine but the caster allows a connection but sends no data.

RPINtripBase is still not working but obviously my network does, so it is now going to get a clean re-install. I will keep you posted for interest sake.

Thank you again for looking over my setup.

[Edit…] ESP32-XBee has a static IP setting and set up correctly it works fine.

2 Likes

Snip is also working now. I’ve temporarily used port 12101 and it’s sourcetable is externally visible.

RPINtripBase isn’t working. I’ve re-installed and still no joy. Anyone know contact info for the developer(s) or a better resource than the rather vague readme.md?

Pleased to hear you’ve got it sorted out, nicely done.

Cheers. Getting an ESP32 to inject 1008 messages was a good exercise in learning about serial comms too!

I might forget the RPI thing and run snip on my tractor unsuitable W10 tablet. :skull_and_crossbones: :skull_and_crossbones:

You’re still a dozen steps ahead of me, last week I learned what an ESP32 is (but this is for a totally different purpose. The autonomous vehicle I am building is running a bunch of tools and I am having to learn to manage these before I can move onto the next stage: building a base station.).

1 Like