Help! AgOpenGPS won’t get an Ntrip correction today. I get a “Socket” error. It was working a few days ago however I’m swapping the tablet between 2 setups, the tractor with an Ardusimple getting NTRIP through Agopengps and the other using a Navspark module which uses RTKLIB STRSRV as it needs 2 serial ports.

STRSRV seems to be working fine and Auscors is up, but in AgoOpengps something weird seems to be happening with the IP address. With the usual IP I can see the mountpoints fine in the NTRIP dialog screen, but if I press the confirm IP buttom I get what appears to be a MAC address and that comes up as an invalid IP.

I’m trying to get to tier3.auscors.ga.gov.au . Any Australians able to confirm the IP that’s working for them? Or is there a way to look up the IP address or change the code so it uses the web address rather than IP.

My guess is the service is either not a fixed IP or it has multiple IPs and it’s gone and changed on me.

using AOG 4.3.10 , we connect ntrip through auscors to Yarragadee in WA.
tier3.auscors.ga.gov.au gives IP
auscors.ga.gov.au gives IP
All seem to be working.

Thanks. That’s the IP I have. Maybe it’s my hotspot then. Using an IPhone 11. It sometimes gives trouble.

Working just fine on home WiFi (off tractor in sim) and seems to be working on hotspot too now. Had to do the driving myself today :crazy_face: :open_mouth: :flushed: :confounded:

So, is that a Windows or AOG issue?

Well, RTKLIB worked and AgOpenGPS didn’t in this case so the only difference I see is AgOpenGPS is using the IP and RTKLIB is using the web address. Why there was a “Socket” problem I’m not sure … could also be IOS as the hotspot maybe? AgOpenGPS could reach and interpret the sourcetable with the correct IP but not with the MAC address that was coming up. Have a small spraying job this afternoon so will try again on the tractor.

I had some issues with my connection (not the same - just drop-outs) at harvest time, at the time also blaming my phone (which I’ve since changed and haven’t had a connection problem since). I did wonder if the AusCORs system has times of high load but I’d be a bit surprised as I’d expect commercial providers would likely take the correction and repeat it through their own servers if they aren’t using their own bases.

I think a recent windows update add a protocol IPV6 probably by default versus IPV4

AOG looks not manage IPV6 in Ntrip dialog so better to accept only IPV4

So the best is to cancel IPV6 protocol in property orf network card of your win10 's pad

sorry image in french but you can understand by picture

you can also stop IPV6 in your internet point smartphone or box


I had this trouble again yesterday and using IPV4 as suggested by bricbric worked great. Thanks!