Ntrip rtk2go

Hi, trying to ease myself into the world of AgOpenGPS but struggling with obtaining an RTK signal. I have been trying to connect to a local’ish basestation through RTK2GO (OXTS1), using email and 2101 port etc. Sometimes I have managed to see the mount point list, but most of the time AgOI hangs up when I try and ‘get source table’. I have allowed the programmes access through the Defender firewall and even now turned it off. I have been experiencing the same issue with U-Centre when trying to update the source table.
I am running the following:
Toughbook CF-19
Windows 10 Pro (up to date)
U-Blox ZED-F9P (Ardusimple)
Firmware 1.32
Rover 1Hz

Any help would be amazing.

I don’t know why ‘get source table’ isn’t working for you

But as a workaround, you can see all the mount points on a map here, click the ‘view all’ button

1 Like

You aren’t banned for some reason from rtk2go are you? Try to see if you can go to the map in the post above from the same computer. I think it’s pretty hard to get banned as a rover though.

1 Like

Not hard at all, 500 reconnect attempts and you get banned. So if you try to connect to non exisitng base or your base goes offline, leaving aog open can get you banned fast.

Best is to try to acces:

If you see caster then you are not banned on that network. To be sure that rtk2go is not down, you can try connecting from other network like phone data (different ip).

1 Like

Another way to check the base station status is to check it’s status page


Just replace the base name in the url as needed.

1 Like

Thanks for the help on this matter, very helpful.
This evening I installed AOG 6.3. Once downloaded I opened AgIO and set the NTRIP to RTK2GO and OXTS1 (‘Get Source Table’ worked fine) which is quite near my location. Once I had set that I opened AOG, connected antenna and selected port etc. I had RTK float within a few seconds, so went out into the garden and achieved RTK FIX, was super exciting to see it.
Anyway, I then closed AOG and opened U-Centre to look at the accuracy and I was unable to open the mount list in U-Centre (same as before). I then closed U-Centre and headed back to AOG where again as per yesterday I seem to have lost RTK data, and when trying to ‘get source table’ it sets the NTRIP Client settings to ‘Not Responding’,

When I first turned on the updated AOG and achieved RTK FIX I had data in the AgIO screen on the RH column, when I have the RTK issue I have the mount etc showing but just dots in the data column.

Turn off u centre if you have it running in the background whilst using agopen

1 Like

I am thinking I might uninstall U-Centre all together, I have turned it off and restarted the PC and then just run AOG but it was the same, I will uninstall U-Centre and try again.

Uninstalled U-Centre, restart PC, still no RTK data found, and NTRIP crashed if attempt to ‘get source table’ as before.

I wonder if you are getting banned when you are trying to use both. If it starts working after a while you are probably getting un banned and when you try to run both you get banned again.

1 Like

That sounds very plausible. I am calling it a day, so will try again tomorrow once it has had some off time again. I hope that is the issue! Thanks for your thought into the matter.

I have opened AgIO this morning and been able to access RTK and the ‘Get Source Table’ worked fine. I guess that moving between AOG and U-Centre was getting me a short term ban from RTK2GO, so hopefully I can now use it in a manner I always have access.
Thanks for help everyone.