Off the simulator

when I turn off the simulator the program does not work.
there is no field, I can not connect the GPS through the comport

1 Like

You don’t have GGA and VTG messages coming in. It does look like you have RMC though. Only send GGA and VTG and it should work.

Also, did you restart AgOpenGPS after you turned off the simulator? You should bump up your Hz if you can. 1Hz is usually not fast enough. Baud rate also needs to match what your receiver is sending. I’m not sure what receiver you’re using but if you can’t change what NMEA messages are sent you might be able to pick fix from RMC to get your field displayed.

the problem is that the program stops working as soon as you turn off the simulator.
the screen freezes

:37:18.822> $GPGGA,0,66
0:37:18.822> $GPRMC,V,N
0:37:19.820> $GPGGA,0,66
0:37:19.820> $GPRMC,V,N
0:37:20.821> $GPGGA,0,66
0:37:20.821> $GPRMC,V,N
0:37:21.819> $GPGGA,0,66
0:37:21.819> $GPRMC,V,N
0:37:22.819> $GPGGA,0,66
0:37:22.819> $GPRMC,V,N
0:37:23.819> $GPGGA,0,66
0:37:23.819> $GPRMC,V,N
0:37:24.823> $GPGGA,0,66
0:37:24.823> $GPRMC,V,N
0:37:25.820> $GPGGA,0,66
0:37:25.820> $GPRMC,V,N
0:37:26.819> $GPGGA,0,66
0:37:26.819> $GPRMC,V,N
0:37:27.820> $GPGGA,0,66
0:37:27.820> $GPRMC,V,N
0:37:28.819> $GPGGA,0,66
0:37:28.819> $GPRMC,V,N

this is a data com port

Ah yes, I see that your frame count is in the 30s it should run <10. Are you running other programs at the same time? You can also set the priority to high for AgOpenGPS in task manager.

Send just GGA and VTG

configured vtg - nothing has changed, as well as rmс

the problem is that the program stops working as soon as you turn off the simulator.
the screen freezes

version 3 works fine

does version 4 work for all users.?
I tried to run on several computers and laptops - none of them will work !!! ???

Are you sure you’ve cleaned up all the user settings?


Remove the complete folder

AgOpenGPS Video Meeting 11 - YouTube If you haven’t deleted everything this is what Brian will say! “Fail!” :grin:

I deleted all old versions
deleted folders
even Windows reinstalled, nothing helps
tried to run on different machines - does not work !!!

Nik when you say the program “freezes” does that mean you can’t click on any buttons or access any settings?

Do you have a working GPS data source on your serial port and is AOG connecting to the right port and right baud rate?

With the simulator off, if you have no valid GPS data, there’s nothing to trigger any of the world drawing, such as the field, tractor and tool, etc. Nothing will happen until it gets a few valid GPS fixes at least.

I can press buttons, but not all functions of the program work in the place where the offset image field should appear, which appears immediately after turning off the simulator, even when I have not yet connected the receiver port

Immediately after turning off the simulator, the program should exit. When you restart it, if you have no GPS receiver configured, you will not see the field image nor the tractor and tool graphic. There’s simply no information AOG can use to draw it until you provide GPS. And most function won’t work either, since they rely on active GPS information to work. You cannot create a field or anything like that.

Until you have connected to a GPS receiver port, you won’t see anything or be able to do much except manipulate the vehicle and tool settings (section widths, etc).

By the way the data you listed before from your serial port contains no GPS fixes. They appear to be blank GGA and RMC messages. Probably means your GPS receiver does not have a fix. AOG requires an actual fix to operate.

Thanks for the complete answer.
I was knocked out of the way by version 3 of the program, where, regardless of the quality of the signal, the data goes and is displayed.
I tried the GPS signal emulator and the program worked !!!
Thank you all for your patience and clarification. You are all the best !!!