PANDA losing RTK, but not F9 alone

Built a Panda box last year and it worked okay, but would be intermittent for RTK fix, so assumed it was my ntrip signal.

Fast forward to this year. Got Rtk working, updating both rover and base and it worked well day 1 most of the day but into the evening it started losing fix. Found if i lifted the box up and played with it that it would get rtk again. Thought it was bad antenna wire,

Then today i had it for 5 min and lost it, manipulated every wire and connection and still nothing. Unhooked the fp9 from the panda board and low and behold got a good hard rtk fix.

What on the panda board could possibly be screwing with the rtk corrections? When its all together i have a good gps signal, just not RTK???

So the F9P is getting RTK fix when off the board with no RTK correction input? But when on the board (which one btw?) with RTK corrections it does not get an RTK fix?


Cant post a picture right now from my iphone so cant remember what version pcb it is.

When connected to the board and the board usb i get an intermittant rtk signal, my thought is loose component but cant figure out what.

When i take the fp9 off the board and connect to its built in usb i get rtk no problem

So if i even leave it in place but unplug the blue usb and go right to the fp9 it works fine but i lose the panda messages and imu of course

My first inkling is the blue usb cable or socket is bad. USB connectors have been a source of issues with AOG. Part of the reason for moving to Ethernet in newer boards. Looks like the Ethernet pins are soldered to the Teensy. Is there a matching socket for them on the board? Is the Teensy running an Ethernet firmware? What firmware is on the Teensy?

What is that micro USB cable coming out of the Teensy doing?

It looks like you’re SO close to running full Ethernet. Depending on your firmware (might need an update flashed), try powering it with the barrel jack and connect via Ethernet.

1 Like

I think that was my issue previously was wasn’t sure what type of power supply to get so stuck with usb when it seemed to work.

12v from the tractor. Use a barrel jack from an old wall wart power supply (router?). Just make sure you use the correct polarity.

Stupid question, but how do I ensure polarity is correct?

On another note before I change to UDP I think I figured out the issue. The ground pin on the fp9 header was loose, gonna resolder and try, but I think that should solve it!

Assume something like this would work?

1 Like

if there’s no smell or smoke it’s good.

Barrel center positive