PCB stopped functioning

Hello everyone,
After a long time I have finally started building the autosteer PCB. I had it all soldered together last week and all i had to do was to wait for the cytron motordriver to be delivered. Before i had the motordriver mounted and connected I could read out the pitch in AGopen and the steering angle simulated with a potmeter connected to the board. Now i have the cytron connected and all of a sudden the arduino doesnt work properly anymore. I can program the arduino still with all the examples in arduino IDE, but as soon as i connect it running AGopen the rx and rx led start blinking, i have tried with another arduino but this gives me the same problem. Can anyone tell me where i need to start looking for problems or has anybody experienced this failure too?
With kind regards

how did you connect the cytron, the problem seems to be bind

Like Tervuren I also think connection problem.

If you connect Cytron to the small +12 V , then all power used must pass D2 which has max of 3A, and now could be burnt.

Cytron must be to 12 V OUT

First af all thanks for the input guys.
Im sorry if i weren’t really clear. The 12 volt circuit still functions, i can put power on, hit the switch and the cytron gets power. Somehow on the arduino side it goes wrong somewhere. The first time i plugged the pcb in the laptop was before i got the cytron and without 12v on the board. At this moment i could read out roll from the pcb on the laptop in AG open. Yesterday i got the cytron and plugged it in to the board and put 12v on for the first time. Still no problems and roll was shown on the laptop and changing while i tilted the pcb. I tested the work switch and the autosteer switch and i think that i may have connected them wrong and that i blew something by testing them but i cant find out what. All together my cytron works if i use the buttons, but my arduino gives blinking lights when i connect it to the software on the laptop.
With kind regards,

I believe blinking is normal function when connected to autosteer port in AGopen program.

Do you have any light on nano when just 12 V to PCB(and switch is on) and no usb connection?

When i give it 12v the green arduino light turns on and also the red led on the pcb.
This is the input i get at the moment from the PCB/probleem

Maybe nothing is wrong, did you set everything in AOG and send to module?

The “drive” function can control the Cytron

Else if only driving in SIM you must make field and AB lines before you can turn on autosteer (at bottom right)

This video is good, se other videos by clicking video button at top right of this forum thread.

Thanks, i have two updates now.
First update is that my configuration failed, i have got my inclinometer working again on the software.
Second update, my 5v converters give 10v on the 5v circuit so i guess this explains arduino’s acting weird.
Does this mean i have fried the converters while soldering? im pretty sure i soldered them the right way into the board.
With kind regards,

Soldering unlikely to have destroyed them both (two different 5V circuits) one for was and one for arduino.
Picture from top of your PCB would help here :slight_smile:

1 Like

Here is a picture of the pcb.
I have used one from recom, the r78E5.0-1.0 it has the same specs as the digikey one.

I made myself a mistake here, the pinout is exactly the other way around as the digikey one. It is a good learning proces so far :sweat_smile:

Good you found the problem, hope they still works when turned around.
And yes that precious dot for pin one, you are not the first to miss it.

Also recheck your optocouplers for right position(dot or notch) :slight_smile:

Another thing. When you only feed power from USB, then Nano tries to feed the PCB with power, but does not have enough mA to do correctly, so your potentiometer-WAS will show very different “center point” compared to when you feed with 5V from PCB

I think i’ll just order two new ones to be sure, since the netherlands is in lockdown and i already have to order some housing, some connectors, a wheel sensor and a new arduino ofcourse i’ll just add them to the order. For the octocouplers i have the dot towards the arduino, i figured this was the way to mount them.

1 Like

I have build my second pcb now and im glad to tell i have got almost everything working on my desk. I can make the motor rotate two ways, mma works pretty stable. switches work and no more stuff burning when i put on 12v. On the setup on my desk I use a switched out old car battery that still gives around 12v, 11,8 to be exact. however i cant get the honeywell rty sensor working properly. when the signal wire is not connected to the board it shows nicely from o.5 till 4.5 volts but when i plug the signal wire in the board i get strange readings. could this be a power problem?
With kind regards, Rik

Problem is found yet, when you fry your board with 10v make sure to also replace the ads1115.

Arrgh, sensitive stuff :frowning:
Good that your PCB now works, and great you found out this fault too.
Have you seen the new change/shift from MMA to BNO085 or CMPS14 for roll and heading ?
There are 2 threads for those boards(just search for their names) and working INO´s for each type them, working on ver 4.3.10.
They provide more stable roll than MMA and also heading.
You don´t need another, MMA does still work.

Thanks for the tips, i have been following those options. For now im trying to make everything work first now, later on ill probably switch to the cmps or bno, or even dual antenna. It all depends on how nice it will work. All fields here are flat so im thinking i might get nice results even without roll correction. Im trying for myself to understand the arduino programme some more first before i start to change things in the code.