Problem with ardusimple f9p and windows seven 7

Hello everybody,

I bought a panasonic CF-H2 tablet with windows 7, I installed AOG without problem, now I want to start to connect each element, arduino, gps. No problem with arduino, but for the Ublox F9P ardusimple, it doesn’t work, there is a yellow exclamation mark on the peripheral détails on GNSS receiver, and I can’t find it in the com port list on Ucenter.

For information, I already parameter the F9P as a rover with an other PC.

Is somoene already have this problem ?



Ardusimple have good support pages. Many threads talking about WIN7 USB driver issues.

This is probably the problem, Win 7 need a specific driver, I think when you install u-center it install the right driver.
I have a “u-blox virtual com” driver on win7 and microsoft driver on win10

the ardusimpleRTK2B works with my windows 7.

1 Like


Thank you for your anwers, I tried some things, but nothing work. So, I solve my problem with upgrade windows to windows 10, and now it works well.