Release v4.3.10 - Finally!

Get it here: Release AgOpenGPS v4.3.10 · farmerbriantee/AgOpenGPS · GitHub

Beta versions of v4 have been out and tried for a while - they have many errors which have been fixed in the release version. Absolutely stop using any v4 that is not v4.3.10

  1. Run “Add or Remove Programs” In Windows Settings and uninstall AgOpenGPS.
  2. Go to YourProfileName \AppData\Local\AgopenGPS and delete AgOpenGPS
  3. Install new Version.

You must install the matching Arduino code, contained in the support folder

This version needs you to set everything based on the configuration you use, and make new environment, tool, and vehicle settings.

The wiki is being worked on, and i will be making some videos as soon as possible. Seeding has begun so i, like many farmers, will be busy for a while.


I don’t know if this is the only way for me but:

  1. Lightbar works in a different direction than in previous versions
  2. MMA (1D) must be set to minus to the right otherwise it works the other way around. I was struggling for a good hour before I realized that the lightbar goes crazy by setting MMA backwards.
    Edit. MMA OK.
    I haven’t managed to adjust the steering so that it stays on the line. Either I make a mistake or it doesn’t match my solenoid valves :frowning:

I have a problem with picking the color.


Best regards,



great job and ethousiastic project

i have same trouble even if i engaged or not the “keyboard” option

i put error message if it can help :See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.TypeLoadException: Could not load type ‘Keypad.ColorPickerControl’ from assembly ‘Keypad, Version=, Culture=neutral, PublicKeyToken=null’.
at AgOpenGPS.FormColorPicker.InitializeComponent()
at AgOpenGPS.FormColorPicker…ctor(Form callingForm, Color _inColor) in C:\Users\Grizs\Desktop\SourceCode\GPS\Forms\Pickers\FormColorPicker.cs:line 24
at AgOpenGPS.FormGPS.stripSectionColor_Click(Object sender, EventArgs e) in C:\Users\Grizs\Desktop\SourceCode\GPS\Forms\FormGPS.cs:line 1165
at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
at System.Windows.Forms.ToolStripItem.OnClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ToolStrip.WndProc(Message& m)
at System.Windows.Forms.StatusStrip.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
Assembly Version:
Win32 Version: 4.8.4069.0 built by: NET48REL1LAST_B
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll

Assembly Version:
Win32 Version: 4.3.10
CodeBase: file:///C:/Program%20Files%20(x86)/AgOpenGPS/AgOpenGPS.exe

Assembly Version:
Win32 Version: 4.8.4042.0 built by: NET48REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

Assembly Version:
Win32 Version: 4.8.4001.0 built by: NET48REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll

Assembly Version:
Win32 Version: 4.8.3761.0 built by: NET48REL1
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

Assembly Version:
Win32 Version: 4.8.3761.0 built by: NET48REL1
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

Assembly Version:
Win32 Version: 4.8.4110.0 built by: NET48REL1LAST_B
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll

Assembly Version:
Win32 Version: 4.8.3761.0 built by: NET48REL1
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll

Assembly Version:
Win32 Version: 1.2.2336.6514-pre
CodeBase: file:///C:/Program%20Files%20(x86)/AgOpenGPS/OpenTK.GLControl.DLL

Assembly Version:
Win32 Version: 1.2.2336.6514-pre
CodeBase: file:///C:/Program%20Files%20(x86)/AgOpenGPS/OpenTK.DLL

Assembly Version: 1.0.7235.37687
Win32 Version: 1.0.7235.37687
CodeBase: file:///C:/Program%20Files%20(x86)/AgOpenGPS/Control.Draggable.DLL

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files%20(x86)/AgOpenGPS/RepeatButtonControl.DLL

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files%20(x86)/AgOpenGPS/Tinkerforge.DLL

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files%20(x86)/AgOpenGPS/Keypad.DLL

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the section.
The application must also be compiled with debugging

For example:

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

I also have this problem which i use when switching varietes of seed in field

Same here. Colour picker not working.


Oddly it works on a near identical CF-D1, installed off the same download!

Remove ALL old installed versions and App data before install V4.3.10

That should help for all the faults coming up…

1 Like

The colour picker is a control in the keypad project - talk about misdirection. So why does it work on some computers but not others? That’s a puzzle!!!

Try downloading the Dot Net 4.8 Runtime from here:

Thanks for advise BrianTee_Admin & Richardklasens

I reinstall the dotnet runtime and reboot the computer without succes


  • I remove AgopenGps software with Windows tools
  • erase personal folder AgopenGPS
  • reinstall AgopenGps and no it works

Ok good - glad that worked out. I wonder why the installer isn’t getting rid of the old version. Windows - Ugh!!!

  1. Run “Add or Remove Programs” In Windows Settings and uninstall AgOpenGPS.
  2. Go to YourProfileName\AppData\Local\AgopenGPS and delete AgOpenGPS
  3. Install new Version.

Haven’t tried full uninstall yet, but… Max section width allowed to be typed is 1000cm…not much good when you have 2 sections 12m each!!!

Like this? Just pick 2 sections and enter 1200 in each.


Ok that works now, dont know why it wouldnt when I pulled into my ‘imaginary’ field!
Selection width box bottom left may have confused a little.
Thanks Brian, hope tractor time going well?

I’ve updated the release so it copies over Keypad.dll with the updated one - what a learning event as usual. this stuff gets me every time! Also in boundary when you click google earth the boundary form closes.

If you are getting an updated release of the same version - like i just put up for 4.3.10 just Add Remove Program in windows settings, then install the updated one, and all your settings will still be there.

Is it just me who can’t get 4.3.10 to work with pwm hydraulics and 6/2 valve, I use ibt2 and have a relay that pulls 6/2 valve which gets power from d4 together with “eng L + R” works with verse 4.1,
4.3.10 pulls and releases 6/2 valve so it becomes a very slow control, even with all settings of max.

You mean the relais for the 6/2 and the EN pins go on and off?
*did you upload the new INO?
*did you accidentally turn on the invert relais button?

@Richardklasens_admin yes, yes and no, had the same problem with 4.2.02

Do you have the auto auto button enabled in tractor config?

Machine_UDP is missing in Supportfiles\Arduinocode

Is it OK to use the 4.1 version??

@Richardklasens_admin if you mean under “guidance” remote / manual I have tried, it does not change anything