Section control is intermittent when on GPs

I am new to agopengps and have set it up to control my 3 section boom sprayer. When in simulator mode everything seems to work fine and it turns each section on and off as required. The problem occurs when the system is using GPS in the section control comes on for a couple of seconds then blinks off and on continuously. It is the Arduino control which is intermittant - the arduino turns the relay switches off and on continuously repeating.

I am not using any auto steer system.
GPS seems to have good signal and it happens even when on manual control and stationary (and so simulating the section working.
I provide power from a 5v supply so as not to drain laptop battery, but it happens using usb power as well.

I wondered if it is trying to do autosteer or something which requires a setting to turn off ?

Any pointes would really be appreciated.


How is your setup?

You are using machine_USB_V5 with nano, connected via USB?

Your GPS Signal is it stable, getting RTK fix? Do you have free Sky view? What is the indicated speed?

Are you driving with your tractor/ sprayer, or are these shop tests?

What is the adjustment of min-speed for section control.

How are you powering the relays? Are they getting 12V? Is the power wire large enough to supply enough amps?

Thanks for your interest
Yes using V5 with Nano connected via USB
GPS is stable and I have an RTK base station which it is connected to (happens both with RTK connected and not connected), middle of large open field on hill so good visibility of sky. For speed do you mean tractor speed ? if so only going 8 - 10 kph.
I have done this both driving and shop tests with the same result - when on simulator it works fine and operates the relays correctly, but when you turn off simulator and use the gps whilst the laptop display correctly shows when the sections should be on or off the actual relays start to flick between on and off.
For the adjustment of min spead for section control do you mean the speed it starts spraying which is in the same section as boom section widths - if so it is set at 0.5kmh (typo?)

I was not sure what should be set up on the work switch page ?

Thanks for this - it works fine when in simulator mode but I will try with a different relay board and larger wire.

The arduino nano is powered by both an external 5v supply and the usb so it is putting 5v to the relays. I will double check the relays work on that voltage as I guess it could be if less power is getting to it when everything is working then that could cause the issue.

Relay boards normally has their own supply terminals

for example:


Double check, if VCC from your board is connected to a appropiate power source

I have the vcc attached to the 5v output of the arduino. I have a separate supply which I can try the vcc and ground to.

Has the Nano got steering or machine code on it? and what is the GPS hz?

Your not hitting the watchdog timer with GPS at 1 hz are you?

I think it’s 2sec the watchdog timer in both, just sounds more GPS related if simulator is ok

Thanks - I have done some further work on it this morning and both given the relay an independant supply and tested with another relay - neither made any difference so I am heading back in the gps direction and arduino now.

As I am not using steering what which sketch would you use for only section control ?

Also not sure where to get the gps hz ? or watchdog timer ?

The only other thing I can think to try at this stage is to replace my usb leads incase they are making the connection intermittent.

Thanks I have now added the independent supply to the relay and the arduino, but it still persists.

Do you use Machine_USB_V5.ino ?

You should post screenshots (AGIO, GPS related, (touch speed signal in aog main screen and you get Hz )… ) and pictures of hardware nano /relayboard, which pins you are using?

If you driving the tractor, and you are simulation mode, do you have the same fault?

There is another section software, look at:
Section control by Switch - Hardware / Section Control - AgOpenGPS

Thanks - I will further test later. I don’t think it was that ino but will try that.

I don’t get any fault in simulation mode at all, even in tractor.

Hi I have done more testing which points further to GPS issue.

I have now changed all cables, tried a different pc and relay board. This really leaves a simple setting issue, GPS or arduino. I can rule out arduino as this works fine in simulation mode.

On the GPS I am using the ardusimplertk2b basic starter kit with baud rate set at 38400. I have not made and changes to the GPS so it is as it was out if the box.

Link to short video of problem

I will try today doing a firmware upgrade on the GPS.

Hopefully I have shown the hertz rate as this is still something I know nothing about

Hello, in your last video we see that the Com7 is set to a speed of 19200 have you tried with faster speeds (38400 115200)?
You have too many useless frames try this config for rover. Note that it does not work if you have a radio link with the base (3,8 Ko)
Configuration with radio communication : Improved konfiguration files for f9p with firmware 1.13 - #122 by CommonRail
Configuration Files - ArduSimple
We also see that there are very few visible satellites (GSV frame) what type of antenna do you have?

Your gps looks like it’s only sending data at 1hz. In the first picture just below IMU it says 1~7.2 the 1 is the gps hz. I’m not sure if it will work at that rate. I haven’t used section control board but for autosteer we need at least 5hz and preferably 8-10hz. Someone else may be able to confirm what is minimum for sectioncontrol.
I would reconfigure your gps to output gpgga and gpvtg at 10hz and see what happens.

ArdusimpleRTK2B doesn’t work(aren’t configured right for this task) out the box.

As said, you have to set to 8 ou 10 hz and activate only GGA and VTG messages.

Thanks - I will give that a go !

Thank you every one for you help - it looks like I am up and running.

In case anyone reads this thread with a similar problem the issue was that the ArdusimpleRTK2B is not configured out of the box.

I used the u-center to connect and from ‘message view’ made the following changes :

Under UBX / CFG in the menu

Under Rate - change measurement period to 100 ms
Under Messages - enable NMEA GGA and NMEA VTG & disable NMEA GSA and GSV

Save and send the message to the unit.

I also did a silly error on my NTRIP set up - I am using and I did not press confirm IP which then puts the correct ip address in the IP box.

The following video also is really helpful

Thank you everyone for your help and contributions - hopefully up and running.