Simply replace bno055 with Adafruit BNO085?

there might be the answer to my question somewhere, but I havent found it. I use the pcb v2 with dog2 and bno055, as I understand for agopengps v5 I should get rid of both and use a BNO085. I ordered that.

Somewhere I read that the imu is now seperate, but in the steering ino is still code for the bno085.
So my question: can I simply replace the bno055 with the bno085 or do I have to use a seperate arduino for that? Do I have to change settings on the bno before installation (I read something about calibration?)? My bno055 is on the roof with 2.5m of cable, is it better to put the new one in the steering box to have a shorter cable or on the roof again?
Sorry for the questions, that I am sure are explained somewhere, but i havent found it. Im very happy that somebody wrote a manual for the software of agopengps v5, a lot of thanks for that. But on the hardware side a short manual how it should look and what items are used at the moment would be nice too. I guess that would be a lot of work and as it changes so fast maybe not worth it.


Just simply replace them both with the BNO085, they work fine on the steering PCB if you want to remove your 2.5m cable.

Sorry for the late reply. Thx for the answer, I replaced it and ag open gps gets the data. So hardware is working, only problem is that its not steering on the line, i guess i have to invest a bit more time on the settings

I have the Problem that Agio looses connection to all sensors if the motor rotates fast, if i close agio and start it again everthing works instantly again. The steering arduino and the f9p are connected to a passive usb switch which is connected with my tablet. If i limit the max rotation of the motor its fine, but that cant be the solution. Any ideas?

You’re losing voltage because of the motor’s power draw? Or interference? I’d run seperate wires for motor power straight from the battery.

Thanks, ill try that.

You can put in a relay that’s controlled by the PCB, that way the motor driver is off when everything else is off.

Thought about that too. But first I covered the USB cable in 3 layers of aluminum foil and a layer of duct tape and that worked great for half an hour, then nothing worked anymore cause the 12v - 24v transformator had a short and blew the fuse. So maybe the transformator was broken before and caused the problems, i dont know, but now it works with a new one. I should look for one with better quality, but i hadnt found one and used a similar 20€ piece again.