Something simple I'm sure (F9P/AOG not communicating)

The issue : Approximately every 30 seconds to minute AOG loses the GNSS signal. In between those times while the screen is up showing GPS signal everything seems to work great. (Seems like the correction age is getting too old or is not being updated fast enough to AOG’s liking though I’m not sure how to prove this)
What I’ve done/know (very little)
I’m running the Tony configs in my ZED-F9P Base and my rover. I’ve set the base to 1000ms/1hz and the rover to 100ms/10hz (I actually tried speeding the base up as well for kicks with no change). The base is picking up about 20 satellites (GLONASS, GPS, Galileo, others are disabled as I can’t pick them up)(location is middle of the US) and the rover is picking up the same amount of satellites. The base and rover both seem to have accurate locations as I can move the antenna and the position changes.
I’m running the latest firmware version and AOG is latest as well (V5.6) base is set as survey-in (though I have tried it as a fixed position with no change)
Baud rate is set to 9600 currently though I have been running it at 115k (I have changed AOG to match the speed set in the base and rover). I snagged a screenshot of when it works vs when it doesn’t but I don’t see any change which leads me to believe the issue is an update issue.
I’ve unhooked the guidance controller so I just have AOG open and then the rover plugged into the computer via USB. Rover says it has RTK fix and is flashing the XBEE>GPS and GPS FIX lights.
Laptop (for testing will run a tablet once everything is adjusted) is a ThinkPad with 8GB RAM running Windows 10 pro with a standard 64 bit processor (Intel I5-7300U)
Just looking for ideas as it’s got me scratching my head. FYI this is my first build so I’m sure I’m missing something simple. Thanks

Please stay at 115200.

Im putting more thought into your issue.

But 9600 is just too slow for almost any modern purpose.

Have you turned off usb selective suspend?
Do the lights on the gps turn off during the outage?
Have you tried new cables?

Is it saying no gps with a blank screen, or is it no rtk but still shows the tractor?

1 Like

I’ll change it back!

Thanks

Have you turned off usb selective suspend?
That one is above my head haha. Is that in the preferences for the F9P or is that in AOG settings?

Do the lights on the gps turn off during the outage?
Are you referencing when I pull power from the F9P do the lights shut off? If so yes they shut off immediately. On the base I’m powering through the Power+Xbee plug so I can plug the laptop into the GPS plug to check on readings in U-center.

Have you tried new cables?
Yes. Initially I was running a USB splitter for the PCB and the F9P. I then got rid of the splitter and plugged in direct F9P to laptop. That didn’t help so I then left the PCB unplugged. Finally I got a new cable (stole one from the wife which I should probably return lol)

It comes up with the red circle/line through the location dot. The entire tractor/guidance screen is replaced by this. Its the same screen if you open AOG and turn your simulator off with no guidance hooked up. When it does work it says RTK fix in the upper right hand corner. Here’s a couple snapshots I took, upper picture is not working lower one is when it does work. Showing the GNSS information coming through the F9P.

I appreciate the help PotatoFarmer

1 Like

I see your running 5.6.15 pre release.

Try 5.6.2 Stable release

2 Likes

@PotatoFarmer
You know its almost like you’ve done this before haha.
Used the ‘correct’ AOG version and like magic no more dropout. I also noted the GNSS signal is updating much more often (signal age never gets above .8) and the signals are shown in AOG much faster. I do greatly appreciate the help! Would it be beneficial to report this into ‘bug’ category?

Yes you can report it, but make sure you put the full version number.

The Auto release versions on github are under construction, and may contain bugs. The green highlighted release the last stable known to work release.