Steer motor stoped working

Hi i have a PCB v2 setup i used last year for spreading fertilizer it worked ok . Since then harvest has been and i have some time to fine tune But the steering motor stopped working i have power i have was i have all as normal but the steer motor wont go i used for sometime last year and all was good apart from playing around fine tuning wich i have the time to do now . So i dont understand why the motor stopped working my thought is maybe the ads115 has gone out im not sure i guess i will have to pull apart and start again any thoughts would be appreciated thanks chris

Try to unplug and replug ads1115.
And maybe also nano, it could be a dry/corroded connector.

I will give that a try
thanks chris

Hmm im a bit lost ive tried all connections I have changed ads1115 still the same . I have noticed if i start up pc with out turning pcb on the was indicator works from left to right as normal as soon as i power up pcb it stops kind of locks up motor controller works from the manual buttons . So am thinking maybe the arduino has a problem not sure if any one has had the same problem i would be grateful for some help thanks chris

Meaning that you power the pcb by the usb cable.
Then we know the nano is ok, because you see the steering indicator change from left to right. Center of WAS is a little off because the power goes backward from nano to was so is no longer 5 V but only about 4 V.
Does the lock up also happen when tablet is running on battery only?
The disconnection could be from different grounding of the items on each side of USB.
Try power up pcbv2 and then connect to computer.
You could also try to reconnect from AOG, maybe USB port number is changing?

wow i dont understand but i took lap top pc up and charged it fully also rebooted nano put back in the tractor and working . Pc runs of the cigarette liter and the battery was flat when i used it but thought the power would be ok so im not sure i do not know what has really changed but working atm

If pc is powered from cigarette lighter, and pcbv2 direct from battery or some other 12 v supply, then you have different grounding, which is known to interrupt USB.
But normally you then should be able to reconnect to USB from Agio.
You could add another cigarette lighter output at same wires as used for pcbv2.

Hi and thanks i will add the pc charger to the same power supply as pcb and see how it goes i never thought of that hopfully it sorts the problem out
So you are saying that because pc battery was low and i started pc up before pcb ive put to much load on usb or com port ?
Well now just fine tune steering settings was ok for spreading fertilizer but not good enough for sowing seed hope to get it sorted
thanks for help chris

thank you this has seemed to fix the problem same power supply for both pc and pcb

1 Like