Steering motor probablem

Hi I was setting up the steering motor but had to invert the motor after that the motor doesn’t turn I have tried witha 12v battery the motor turn does anyone know what’s going on ??
As well when I turn the motor by hand there is 2 lights on md13s that turn on .

My modified cytron also does that, and the auto steer works, so no problem there.

That’s all you changed?
And what kind of motor?

its a 12V DC 45mm Planetary High Torque Gear Motor with Encoder 755 Motor, 10mm Shaft from Gimson Robotics

yeah and i have tested there isnt any power coming out
i tried the ma and mb still no power
but if i turen the motor by hand the lits on ma and mb turn on
but i thought with the mod welding the wire on the nc it shouldnt prevent back feed so should the lights be turning on ?

Do you have the 4th wire connected to the citron?

I thought so too but it didn’t on ours. Must be the LEDs are after the modification.
Buttons MA&MB won’t work unless the auto steer is engaged in AOG

With the power off check with a multimeter for continuity from the arduino pins used for pwm and direction to the cytron pins

Quick way to test if the signal can get there

i tryed all of the pins on the arduino for continuity none of them have
i saw online the pwm is d5
an dir is the d6 but nothing

With one probe on the arduino pin, follow down the trace toward the cytron, checking each solder joint along the way with the other probe. You will soon find where the issue is.

Do this for all of the traces that connect to the pwm pins.

I have tested it like on the pic were the circle in red blue and yellow and i have continuity
but i thopught it was on d5 but it isnt
so im thinking that the cytron is dameged


By changing something in the AOG settings, you might have send other information to nano on the pcb.
So show us your screen in AOG, and also setting page. (Are both autosteer icons bottom right green? )
In steer settings did you try manual steer? (Still need you to activate autosteer by either switch or button, if you have not set aog to manual engage)
In this screen you still have to (after opening a

In simulator it is also possible to get PWM without opening a field. but I still had to flickr my button to make the steer icon yellow.
The flickr is needed at LEAST one time after startup of AOG, I did not find a way to get PWM without doing that.
I had assumed the NONE setting could do that!
Button is Flickr (to GND)
Switch is keep holding connection to GND, on the steer input.
In this setup there were no WAS, so to get PWM to other side I invert WAS
This was tested on a TEENSY, and later I did test on nano ant found the NONE setting worked alone by clicking the manual in steer settings.
Switch and button are same as teensy.

1 Like