Stuck… again! Last try

This is getting embarrassing.

As many of you here will know, I have worked on getting AOG working for probably 18 months and I’ve had a lot of support from you guys fit which I’m grateful.

But right now, I am back to square 1. :frowning:

Basically autosteer will not work. Everything else works, but autosteer just remains silent.

Last week I had v5 working. I noticed the motor was reversed, so I hit the invert motor button in AOG5 and everything just stopped.

I do not have a BNO085, I have the BNO055, so I assumed this was the problem and reverted back to V4 which supports the 055. Flashed the nano with the autosteer USB ino, fired up AOG, connect the PCB to AOG autosteer and ensured it’s reading the WAS.

Test the Cytron board from the manual buttons and it works, so it has power.

When I connect the PCB to AOG, the LEDs on the nano go crazy, so it’s doing something.

I go into Autosteer, try to manually control the motor…. Nothing. Set up a simulation, no action from the motor.

I’m seriously on the brink of giving up, but before I do is there some small step that I am missing? Is there something I am forgetting to turn on in AOG?

One thing I have noticed is that there is no voltage across the on / off switch. Because I want this always-on, I have just bridged this connection with wire. Should there be voltage across this?

Also there is no voltage across R8 (which is just a wire).

Everything else tests out fine on the multimeter.

Does anyone have any idea what I’m doing wrong, yet again?

Do you have a voltage of 12v at the output of 12vout?

Yes. I’ve measured the 12v circuit at various points and it all looks fine.

Do you have a bum Arduino?

Possibly, but I doubt 5 are all bum. I’ve tried them all, just to rule this out.

Am I the only person who has these problems? Has everyone else got theirs working reliably?

Good news you are still in the game, it worked at one point.

Another good sign, I was stuck at this point for quite sometime until I found out I had to open up the lower hidden menu on the auto steer config and press the tractor to activate.

I also had an issue where it looked like comms were coming from the board, but agIO required a re-boot to actually start talking.

This is to be expected, measuring two points on the same wire at the same potential is 0v. To chase down power issues put the multimeter between main ground and the point you want to measure. As long as you are measuring volts you cannot fry anything, the meter has too high a resistance to enter the circuit.

Also try removing the nano from the board before you flash it, I have noticed especially on the clones that they can get confused and not flash if other inputs are active. So there may be a possibility of version mismatch.

So if you are seeing the WAS work, do you see output PWM values in the auto steer configuration screen? If You see PWM, check your Cytron wires. If you used screw terminals put a little solder on the end of the wires before reseating them in the terminals.

Did you remember to ground your steer switch?

1 Like

I’m just checking everything you advise. Back soon.

Is your minimum speed set to 0? From what I remember, 4 did not stering if it was set to more than 0

I have gone back to 5 and it’s working. I have no idea what I did differently.

Thanks for the support, I’m going to sit here until I understand where I am (constantly) going wrong!

I did flash the nano outside the PCB, maybe this was the fix? I’ll check.

If you do narrow it down to one thing be sure to let us know.

The AOG creators who have been here from the beginning know this stuff inside out, so their brain fills in the gaps. I am like you starting an install at v5.2, some of the information seems not so obvious, but it is getting much easier now with one working unit.

Heh, I wish I was a newcomer, then at least I would have some excuse. I’ve been working on getting this stable since v3 was released :expressionless:

I will definitely post up any bugs I find.

Same here, I finally got interested in AOG after seeing V3, started getting serious and ordering parts in V4, Finally building in V5. Really its a case of the first is the worst, I soldered together and setup 4 more working boards today in a fraction of the time of the first.

1 Like

The easiest answer is you did not activate the switch/button option inside Arduino configuration. You have to choose one and be sure that the down right arrow becomes green after you activate the steering button.

1 Like


It’s really quite satisfying making these boards, isn’t it? I built another V2 board yesterday just to rule out (intermittent) hardware issues and did it in 2 hours.

Didn’t even know how to solder, nor what an Arduino was before I discovered AOG and have learned a huge amount from this (and spent a fair sum!).

1 Like

I’ll check this tomorrow and get back to you. My feeling has always been that I’m missing something really obvious, some button.

They are fun to make, but after I am done 10 V2 boards going to switch to @GoRoNb 's SMD boards. Building the V2 board makes it easier to understand the system what experiments I can do with it later. That I find is the real fun of this, farmer designed software upgrades.

1 Like

Did that fix it? If not, we could try changing the default motor rotation to reversed in your arduino code to rule out some problems, then work your way back to see what is going on.

Yes, it’s all fixed and working now, I just need to get this out for a field trial. Will let you know how that goes.

Thanks for your work on this.


I hadn’t enabled the Enable Switch option in AOG!

This has been the bane of my existence for years, literally. I had assumed, wrongly, that by shorting PD6 the switch was always enabled. Then it was just a case of hitting the autosteer and u-turn buttons in the main GUI.

I had completely missed the Enable Switch option in the AOG submenu. The Steer Indicator icon told me the problem.


If you are going to short it, short it high. Set a resistor in pin 6 and feed the resistor 5v. It is a pull up pin, and this is what it does internally. But for state of mind, you will know it is held high.