Tractor jumping when backing up

When I’m backing up the tractor position in AOG suddenly jumps a few meters (dual antenna setup, Stanley). When moving forward again there’s another jump back to the original position.

If I set Antenna distance from pivot =0, there’s no jump anymore. if I set another value for distance, the jump distance is approx two times this value.

Stefan found the error in AOG code under “FormSettings”. There are two minus signs which could be erased to probably fix the issue.

Sorry, I gave you a wrong Information. The error is not in “FormSettings” but in “Position.designer.cs”.
Delete the minuses I marked red and the map will no more jump when changing the driving direction.
I think the minuses marked blue should also be deleted although they are not relevant for the “jump-bug”.

2 Likes

I drove with PureP and saw this issue, too. I will test the modification from StefanA.

Tested Stefan’s modification yesterday. The jumping issue is solved but autosteer didn’t work while backing up. Driving forward, autosteer worked but not when backing up.

Did you drive Stanley or PureP while testing? In simulator mode autosteer still works while backing up but only with Stanley.

I’m quite sure I drove Stanley. But not a 100% sure.

And you did reengage autosteer after changing direction, as you passed below min speed in the process :slight_smile:

With the actual AOG version running, I just back up without any other action and the tractor stays on the line (Dual heading, in Stanley mode).

But there is this jump.

Same here. Reverse driving in Stanley mode works no longer with the modification. (But with PureP reverse driving never worked, so what.)