UDP Auto Steer


new user here, trying to get UDP Auto steer working based on Coffeetrac’s Autosteer_ESP.

In the AOG window it counts UDP receiving but never shows as connected or able to connect to the auto steer module. I am thinking it is a versioning issue or something but i have spent weeks on this and can’t work it out. Anyone else solved this?


I think the coffeetrac code is not V4.3 ready.
Mine is based on coffetrac code and made compatible to the new versions plus some new features:

1 Like

Hi! How does esp32 fit into pcbv2?


I will try that tonight and see how it goes. can you explain what the dfferences are? PGN’s?

Since v4 serial packages must send pgn, UDP allways did. V4.3 has completely different steering algorithms

No ESP32 needs a different PCB. A german guy is designing a uno/esp32 multi platform PCB. Not sure if he is already using it

Thank you! Why is esp better? More stable than the arduino?

Im also making some boards i made for this to test with. Hope to offer them once they are all sorted

1 Like

The ESP offers on board blue tooth if you ever plan on Bluetooth corrections for RTK. As well there is more pins if you plan on controlling other stuff on the tractor.

Please post the Gerber once you have it completed. I’m very interested.

I have compiled and uploaded your code and it still says not connected. the UDP counter is incrementing, so there is data? Any ideas?

The serial port windows doesn’t show incoming UDP data. There is a debugmode in the ESP32 code. With it you can see data ect. on ESPs USB port

What does the next line of arduino code mean?
Need to change the numbers?
//ethercard 10,11,12,13
// Arduino Nano = 10 depending how CS of Ethernet Controller ENC28J60 is Connected
#define CS_Pin 10

Yeah i figured it wouldn’t show in the serial port view. I did see the data stream from the esp32 usb port ok, and like i said AOG sees udp data as it is incrementing the udp counter but says autosteer is not connected.? Any ideas?

Debugging UDP is not easy. AOG only shows UDP NMEA messages. (in the serial port window but not when a field is open) It is not clear to me where the UDP counter is referring to, GPS, Autosteer, Machine?? I have trouble getting section control to work. On the AOG machine I can see the machine-control packets coming in with Wireshark. However, AOG does not seem to receive them. UDP is set to be active
but Netstat does not show AOG listening on port 9999.
Sorry, couldn’t answer your question, only add my own…

Sounds too me like AoG needs a bit more UDP debugging info.

Maybe the esp setting “send data via” is wrong.
Debugging UDP can be done with wireshark. There you can see which sentences are send and the content

I only have autosteer module powered while testing to ensure it is the only thing that can be incrementing the udp counter. I have tried wire shark but I don’t really know how to use it to only view certain packets. I will look that up and see what i can. I also tried to use it via the usb implementation but that doesn’t work either …

Do you have WAS connected? or else it does not work. (security feature)

No i don’t… will try that thanks