Unable to connect to module - RC8 App

I get an I.P. address when I install the firmware for Nano Rate. However it says it cannot load the PCA9555 I/O expander. Am I doing something wrong? Do I need to do something different with the Nano?

RC8 uses a MCP23017. It can be set in the rate app Modules dialog.

Thank you!

I am so embarrassed that I cannot seem to get this going. I seem to have a good firmware install, and when I connect the ENC28j60 to the nano, i can see it start to attempt to communicate through UDP.

However, when I remove the serial connection and hook my compter up to the UDP connection I cannont seem to get the module to talk over the connection. I set the subnet according to the videos but I get no activity over the ethernet monitor. When I attempt to send the RC8 configuration nothing happens. Its say loaded, but again I am still seeing no ethernet activity.

Your tablet subnet address is 192.168.10. Either change the tablet to 192.168.5 or change the module to 192.168.10

The tablet isn’t allowing me to change my I.P. to the module address. How do I change the module address?

My mistake, I should have said change the app subnet. When you select the local IP it allows you to save the subnet in the lower right of the page. You can check it on the comm diagnostics page.

IP settings

I tried saving then sending the correct subnet, but it never changes on the comm diagnostics page.

It shows 192.168.0 now. Previously it was

That was on my tablet, plugged into the module. This is a different Nano and shield, I was hoping to repeat the process. My tablet is doing the same thing, I am on my office PC at the moment trying to figure where I am going wrong.

Change App Subnet.zip (559.2 KB)

A short video of how to change the app subnet. In Comm Diagnostics it starts out with 192.168.56. To refresh after changing, the dialog is closed and reopened. It ends showing 192.168.5.

I have the board out of the rig and hooked to 12V power. I have a different ethernet shield, and freshly flashed Nano. The ethernet port lights are on even though its hard to tell.

I have changed the subnet to match my IP
IP settings

There is still no communication, it doesnt connect to the module. I am not sure where I have gone wrong…

Thank you for all of your time helping me!