Unstable GNSS

I’m working on my first AOG setup, and I’ve got it to the point where everything is communicating, and it steers good in drive. I’m having issues with the gps being terrible jittery/moves around. This video is while driving slowly across our driveway.Any ideas?


Hola, que modelo Gps estas usando y que hz rate tiene?
Que tipo de sentencias emite el GPS? Sería bueno que presionaras sobre el cuadro donde se muestra la velocidad (en la parte superior derecha de la pantalla) y nos dejaras ver como son tus mensajes gps.

Does this help? I am using an old mojoRTK system for nmea, which is outputting gga rmc and vtg, at 10 htz.

Los mensajes que e tienes activos parecen ser los adecuados, pero no son fluidos. Que rate de baudios tienes configurado para el puerto de salida gps?
Deberías probar con 5hz, 8hz y ver como se comporta, pues con menos Hz se necesitan menos baudios y podría corregir el problema

I have tried every combination of baud rate and Nmea hertz I can imagine. I’m mostly running 38400. It is rock solid when I am sitting still, but as soon as I start moving, it goes crazy!

You need to determine where this nervousness is coming from. This can be done by the receiver, but can be made with the help of corrections. Disable the corrections and repeat. If it doesn’t help, change the configuration file. It is posted in one of the posts. I use 8 hertz.

I’m using mojoRTK by Leica, so i have no configuration to do. Here is a longer video showing how it is stable when stopped, but erratic when driving.


Ve a DATA SOURCE/FIX y Selecciona GGA
También heading from FIX, 2 metros

I tried this and it makes no difference… Is it possible something is wrong with the Nmea string coming from my mojoRTKPXL_20210227_231326071 PXL_20210227_231247601PXL_20210227_231202539

Its not stable when your parked either.

Usually your NMEA sentences should output together all as a group at 0s, 0.2, 0.4, 0.6, 0.8, and 1.0s for 5hz. 0,0.1,0.2,0.3… for 10hz. So really your sentence labels should never really leave the screen, just the data should update.

You are getting some data but its kind of all over the place. Can you send pictures of your port configurations for each device? What are your parities set to?

Is there another message system enabled on the mojo other than NMEA? The AOG NMEA parse is great, but I have not tried fooling it with some non NMEA mixed in the data yet. That may throw it for a loop.

Leica require money to unlock NMEA of suitable accuracy for AOG.
Leica NMEA
Would be good to see a recording of the NMEA to see if the noise added can be filtered out.

1 Like

And the high accuracy mode unlock costs more than a few Ardusimple RTK receivers?

Do you have the latest software in the mojortk? Looks like they made the nmea activations free and included them in the software update.


I’ll check out some of those ideas when I get some more time.

I put this on the telegram group also, but my problem was that I had created my field while in simulator mode, and never thought about starting a new one when testing in the tractor, so the field coordinates were too far away from my actual location! Thanks to @BrianTee_Admin for catching my issue!