Vehicle settings file setup

I’m trying to create unique vehicle settings files for each implement that I will use this season and I keep getting a “fatal error with settings file” when trying to load a vehicle.xml. even happens with the default vehicle. Any ideas what it is not happy with?

not a answer but i got a little question about the vehicle selections to. i wanted to save two tractors and different implements but it seems that i cant save them sepret i mean two tractors you can select and diffrent machines per tractor.

There is a pinned message on telegram:

Brian Tee, [28-01-2023 14:41]
Appdata has the “working” copy of the exact same settings file used and sourced in 3 different places.

  1. The default XML file. This is stored in the program folder called AgOpenGPS.exe.config. This has every setting ever used in AOG. AgIO has one also. When you first start AOG, it uses this file and creates a skeleton copy of it in AppData to be the working copy of any changes in settings you make.

  2. C:\Users\Grizs\AppData\Local\AgOpenGPS\AgOpenGPS.exe_Url_djk0qumzckoxguu0ndtkmwiiikypywwm\\user.config This is the working copy of that same XML. When you move a window, set your sections from 3 to 5, set a color, change your wheelbase - every last change is set there. But only the changes. AOG looks there first for the setting and if it finds it, it uses that value. If there is no entry for that setting in Appdat, it goes back to the default config in the program directory and uses that. As you set more settings the file user.config gets longer. You can see the folder thagt is generated is unique to where the program folder is and the version running. Move the program folder and you have a new config folder. Delete the folders - you use once again the default settings from AOG.config and start all over.

  3. The Saved Vehicle.xml fies folder in Documents. This is just a copy of whatever was in Appdata. When you Save a vehicle all you are doing is copying the config file (which is type XML) to a vehicle XML file you have named and want to keep those settings no matter what happens. Every time you change something or leave Config Form and hit ok, the Appdata XML overwrites the Vehicle Name .xml file in Documents so there is always a copy of it. In the settings config file a setting keeps track of which setting file you have (YourVehicle.xml) so it knows where to keep a copy of it saving it.

When you start AOG - it goes to AppData and looks for the latest settings and if it doesn’t see one, goes back to the porgram folder settings and uses that setting.

When you “Load” a vehicle - you are taking your vehicle.xml file and overwriting the config.user file in Appdata so AOG can now use those settings you want.

Brian Tee, [28-01-2023 14:42]
So go ahead delete Appdata folders. Start AOG fresh using the default from program folder. Load a Vehicle file from Documents and you are good to go.

Brian Tee, [28-01-2023 14:44]
Now for the problem of older versions. There uses to be 2 groups in the settings file - settings.settings and vehicle.settings. The vehicle group was added to the settings group as it was getting too hard to figure out what was stored where. So older files with both are rewritten and saved as a single settings.settings group and can’t be used in older versions again.

Brian Tee, [28-01-2023 14:45]
Save a copy of AgOpenGPS/Vehicles files if you want to save all the settings.

Brian Tee, [28-01-2023 14:46]
The only odd duck is the language setting - it is stored in the registry. So it doesn’t matter where you store or which version you use, your language is always your language and needs to be actually changed from the menu before it will change

Brian Tee, [28-01-2023 14:47]
Hope this helps.

1 Like

I remember someone having same problem, but can´t find it again. But as far as I recall he reinstalled AOG and problem was gone. Read post above, as you might be able to cure problem by deleting the aog part in APPDATA
I assume you use the latest version of AOG !

Did you manage to get rid of the fatal error message at all? I’m currently upgrading from 5.6.2 to 5.7.2 and getting the same message. Before I start hacking the xml files to copy across the information, I wondered if you;d managed to get older vehicle files to load?

I did not get fatal error problem, still using Dell venue 11 that started with version 4. All fields are still there.

But I do not use any automatic implement settings, apart from the painted area on screen.

AB lines are there. U turn and boundary alao.

Just for completeness, I got rid of the error by updating my .net framework files. Turns out that whilst I’d upgraded Windows 10, the .net framework had failed. Once this was updated, the settings file worked perfectly.

1 Like

When upgrading to the latest version, I’ve hit the issue again and this time all .net framework files were up to date (by the way, if I’m not mistaken, for reference AgOpenGPS v5.8.3 uses .net framework 4.6, but .net framework v4.8.1 should be fully backwards compatible).

I’ve tracked the issue down to the way I was installing it:

For ease of use, I’d set up a folder in the Programs Folder called AgOpenGPS and when I wanted to upgrade, I simply deleted all the contents of that folder and copied the new files into it. That way the shortcuts I had all just linked straight away and so I could access the updated program using those without any changes.

As per Brian’s comments posted by Lars above, the settings are held in a folder in AppData with a long unique name (AgOpenGPS.exe_Url_ followed by seemingly random characters). This contains a subfolder which is named using the AgOpenGPS version number, which contains the user.config file. When I started the newly copied application file from the existing Program File location, it added a second subfolder named after the new version into the existing folder with the long, unique name, so I had two subfolders, 5.7.2 and 5.8.3. Simply deleting these folders (and the corresponding ones for AgIO too) did not seem to solve the issue, even when I was left with just one subfolder with for the correct version of AgOpenGPS.

The latest version fully worked on another PC, but there I had simply extracted the files to a new stand alone folder on the desktop. Upon opening AgOpenGPS from there, it created another unique long-named folder in AppData and put the subfolder 5.8.3 in that. So in AppData, under AgOpenGPS, I had several folders with long unique names and each only contained one subfolder relating to a single version.

The solution on the original PC? Simply use a different folder for installation. I still have AgOpenGPS folder in Program Files, but copy all the new files to a new subfolder for each version. This then creates a uniquely named folder in AppData for that version’s user.config file and I don’t seem to get the errors any more.

The shortcut pinned to my taskbar no longer automatically works, but that is easily fixed.

Hope this helps others.

We had the same issue as EdwardC but with the AgopenGPS - version 6.0.10.
After some time we found out that the AgOpenGPS - folder shouldn’t be stored in the Program Files folder.
After we moved the AgOpenGPS folder to the desktop folder as suggested by Brian Tee, the vehicle files loaded without any errors.
This is related to the restricted writing permissions in the Program Files folder.
For the version 6.0.10 the AgOpenGPS folder must be located in a folder without any write protection.
By the way, thank you all for your great work!
We had a lot of fun with Agopen in the last months!


Interesting problem related to this if try to start AOG with a button on the panasonic tablet I get the fatal error when trying to load vehicles. If I run from a desktop shortcut its fine. Based on the messages above I suspect this is because the working directory is not set to the agopen directory when i use the button to start the application where as when using a shortcut you have the option to specify the startup location. I suspect there is a path configured in agopen that uses the current working directory and it must have write access to that.

I was able to get around this on my Getac tablet by setting the button to launch the shortcut on the desktop.

Can you show me what you set to by default it actually inserts the original executable even when i click the shortcut - if i force it to the shortcut it doesn’t run at all


Desktop shortcut settings

Shift+right click the desktop shortcut icon and “copy as path,” use that path for the button path.

Probably a lot easier to just store the program in Documents/AgOpenGPS_Releases but this is what I did.