Version 4.1, Download Release 4.3.10

Please update to v4.1 Version 4.1 Install of AgOpenGPS

There have been many many versions of v4.0 that were used for testing and debugging. I have been noticing people having trouble because there were lots of issues with them and even though you may be using the newest v4.0 there are the old settings messing it up.

v4.1 solves this problem. None of the old settings from vehicles, tools, environments will work. Old fields from v3 will work, however the mapping will not be saved. Best you can do is delete all v4 fields and create again if you find there are problems.


I love the new 4.0 Brian. I will install 4.1. I love the full screen. It keeps from accidentally hitting Shortcuts on bottom of tablet. I’m sure there’s a better way to get to my keyboard to enter field file data. I have to get out of full screen and push the virtual keyboard at bottom right of screen. How is everyone else getting to their keyboard? Is there going to eventually be a full keyboard on AOG like the numbers keyboard.


Ya another one of the Windows “features” I can’t get around. It would seem an onscreen winforms control is the only answer

Windows 10 tablet mode won’t pop up it’s built-in keyboard automatically? It used to work.

Not with my device. I just tried it in tablet mode on ver 4.1. Maybe theres a setting somewhere I need to change.

If you switch to tablet mode it should work

The keyboard pops up but covers half the screen in what you are just trying to type. But this is not a serious problem. Maybe consider some small blutoth keyboard and mount it somewhere :slight_smile:

Solution to my laptop and UdP hookup. My home network [] so laptop shows up as [] under the AOG page. Would not connect to AOG via UDP.
Solution, turned off wifi, then set Ethernet adapter to manual ip4 at, same for it’s gateway and DNS server. Then laptop showed up on AOG as [, was then able to set AOG module side to [] and Bam AOG connected to the nano board. After I turned wifi back on, laptop shows up on AOG again as [] but AOG stays connected to the nano, hope that helps others, please comment if you think this is not correct

try as your ip to send on ( the right side box in udp settings)

Ok, will try that this morning. I thought I had but will retry. Any ideas why my machine will not connect I sent the machine USB to the second nano and when I plug it in with the USB cable it won’t show up. Is the machine USB INO for the relays that do sectional

I’m back home again, i can hook it to a physical nano now to try. I’m pretty sure all that is wrong is it doesn’t show up in the textbox, but the thing works.

Thanks Baraki. I will look into it.

I tried that and could not get it to connect until I changed my ethernet adapter on my laptop to as a static with the same gateway and DNS servers as my router gives out in my house with it at 1.5 it works with it at 86.5 it does not work The odd thing is that when the Ethernet port is 1.5 my laptop still shows up as 86. 33 because it’s hooked to my home network and I set the AOG to and it works

Did you chaneg your arduino ino’s to match your 86 network?

I’m thinking today will be a good video making day. Not going anywhere or doing much else lol

I did not change anything in my Arduino code.

2 choices, make everything the same network like the .86. or just use the default (much easier)

I changed my Arduino code in 3 places to the 86. The Ethernet interface, the gateway and ip address of where to send back. If I set my adapter on laptop to static with everything 86 this now works. Nothing works if I leave my laptop on obtain IP automatically. Flipside is that if I simply change the 86 to a 1 on laptop static it works with AOG original Arduino code. Probably just way easier to set laptop Ethernet to static with a IP like

Brian, I have nothing hooked up on steer, imp or remote on board. No jumpers or switches, my plan was for a footswitch like an on/off for steer and then I think we talked about a steering wheel encoder for steering wheel movement on the remote to disengage if steer wheel moved. Does that sound correct? Is imp going to be used for anything

The switches went from 0 to com correct? When the switch closes it closes those to connectors? Should I have a jumper or switch on steer one now for testing stuff on bench