WAS Issue

Wonder if anyone can help with an issue that’s driving me nuts?

Have installed an autosteer system on an ATV with a linear actuator as a WAS (KTC-125: KTC 275-450mm Transducer Displacement Ruler Potentiometer Injection Machine | eBay).

When connected it seems to detect the steering angle fine. Just zero it and, if I turn the bars left / right, then I can see the steering angle move correctly the AgIO autosteer config.

The moment I set it to live autosteer (or even PWM test), it immediately runs to full steering lock. Every time, regardless of how I adjust the settings. As soon as it’s connected, full lock.

If I let it run in the simulator, I can hear it trying to adjust voltage on the u-turns, but it just remains fully locked.

Does anyone have any ideas on this?

Sounds like the motor direction should be reversed? There’s a setting for that, or just flip the wires to the steering motor.

I’d love to see some pictures of the setup!

I have tried reversing both the WAS and the motor directions with no effect. Will try again shortly.

Will also post pics

Hopefully only one at a time :slight_smile:
AND you have selected the correct motordriver (cytron or IBT_2)
PLUS send+save after each change?

PWM test: so you say it go to full lock when you set it at 1 degree in this screen? ( I have no steer pcb connected)

Lol, yes, one at a time :slight_smile:

It’s when I hit the PWM button (tractor goes green) that it goes to full lock.

If you let it go to full lock, then press the invert motor direction and the send+save button. What happens?

Was the ads1115 installed on the pcb by jlcpcb or did you install the suface mounted option yourself?
Had similar problem myself that the wheels went full lock , turns out that because i added the suface mounted ads1115 i also needed to add a resistor, this then cured it for me

1 Like

So you have a correct functioning WAS because you have Zero angle before you press the “PWM” button.
So how did you connect your Cytron, it is like it have switched the wires for L R and PWM in, which would tell Cytron to go full PWM as soon as you activate autosteer. (but that is only true to one side because one side is 0v the other is 5v)
Does your cytron buttons work (or did you make the modification to Cytron)
IF you did the mod, check again for correct wiring.

1 Like

Had this happen with one of my setups. Was with pcb v2 and I just loaded the code on the arduino again and it worked after that.