AgIO GPS has coordinates but AOG does not show it

I am trying to use position output from an emlid m2 through bluetooth. I stopped the simulator mode resulting in a no gps message showing up.
I then bring up the agio interface to select the gps signal source
Using port 8, nmea sentences began streaming
However, no latitude longitude shows up!
Any assistance will be much appreciated.

What is the header of these nmea sentences? we can’t read them on your images


Thx for taking a look.

This is a screenshot of the nmea messages that just continually updates …

I have a c099 f9p on Bluetooth and at every AOG start i must change between 2 com speeds so try 19200 and 38400.
But you probably have to change your f9p setup to only output gga and vtg

I see your using an emlid m2, you can select only nmea gga and vtg on the same output page.

Talker code gn or gp should not matter for aog, but you will be able to change these as well.

I am using the beta firmware over winter, but its the same for the previous version.

Just deselect anything you do not need.

Yes, I was about to point out I am not using f2p. I am able to access the screen you are showing but when using Bluetooth as the position output mode, changing anything on the page result in a write error. When I shifted to serial, reachview3 says its green and connected. Is this also your case. I was hoping bluetooth works since if it is only serial that will provide the gga and vtg messages have to purchase a cable or customize one myself.


I will look into this as well.

Reach m2 has Ublox F9P inside.

“changing anything on the page result in a write error.”
When using UBLOX U-Center with F9P, updates can´t be done at lov com port speed: Maybe bluetooth is too slow?

But apparently the reach has a setup page, just remember to set 10 Hz when you use Reach as rover :slight_smile: and only select GGA and VTG

Updates on reach are done via their flash tool, they are only done over WIFI.

What he is trying to do is receive gga and vtg over bluetooth for a non Panda AOG setup. This will work.

But if there is an issue with it, I will request help on the Emlid forum and get it cleared up.

Ive got it solved!

The connection data window in AOG is broken on the com ports page. It will connect but show no data.

Here it is working in an older version


Now lets try the latest 5.6
The gn or gga does not matter, gps is displayed here only after the second time you come in? bug?

Try this button…
The data is always here

But in 5.6 the path back for the corrections is broken.

So Emlid still is awesome, AgIO has a bug for bluetooth ports.


Still using AOG 5.6 and got these data

The screenshots replicated the one you’re seeing in v5. What do you mean by the path back to the corrections is broken. What specific section of the screen manifest the broken status? Thx

Agio used to send corrections through bluetooth to the emlid in V5 and it still works flawlessly in V5 when tested today.

In v5.6 the corrections freeze and the emlid stays in Single. So there is an agIO bug.

Ive always used agIO to connect to NTRIP, after V5 switched from using the Emlid as rover to a F9P board.

I use Emlid for base still as it is a huge value with the ease of PPP and Emlid caster for Ntrip.


Setup my m2 as base and RS2 as rover. Connected to RS2 via bluetooth and I got an RTK fix quality!

Not sure what I did but the setup was done in AOG 5.6

What are you using for correction input on the M2?

I see agIO is sending no data from your photo.

This is a neat feature of emlid your corrections can be completely independent of the output interface.

Hi! the m2 is serving as base (sending correction input) and the RS2 (receiving the correction) as the rover and the one connected to the agIO by bluetooth. I will assemble again my setup try to figure out if data is being sent by agIO. Thx

Its easy to see, if agio was sending the rtcm3 data there would be a number of bytes shown on the left hand side of the Antenna icon in agIO.

In 5.6 the number on the left freezes and the corrections from agio stop.


I am still stuck with agio showing gga and vtg as well as quality being RTK fix (System data). No information is showing up on the left side of the agio screen beside the gps icon (“Listening NTRIP …”). This is still the case even if I use v5.1. Stilnik (Sparkfun gnss rtk facet bluetooth - #5 by Larsvest) was able to resolved bluetooth communication problem but can’t point to what exactly he did to come up with the solution. Any other thoughts on how to resolve my bluetooth gps connection problem?

By the way, my setup for now is just the computer agio/aog software. No aog board connected.

To solve this we need to be very specific, computers are very not smart machines.

So there are two communications streams
One is the NMEA going from the GPS to AgIO then passed to the guidance program
The second is the RTCM3 data from the base, to the ntrip server, from the internet, to Agio

We can only solve one at a time.

So we will solve the NMEA stream first, the GGA and VTG message. So using Bluetooth it gives the computer multiple virtual serial com ports once initiated. You have to manually guess the port in agIO, if its not easy to determine the com port in device manager on windows. Pick the max baud rate in agIO when checking ports for bluetooth.

A disclaimer Serial ports work but are aggravating, because once you reboot your computer their is no guarantee, and almost a certainty it will change the port numbers on you. If you are monitoring any Serial port from another program, it will block any attempts for any other program to use it. Also serial ports can be hogged by some offending software that requires a restart of the computer to release the com port to let another program use it.

1 Like

Hi PotatoFarmer,

The GPS data from the RS2 is corrected via emlid software before it is routed to agopengps. This is confirmed by the quality of of signal for example being RTK fix. So I guess, I can get a way from agio not processing the gps signal with ntrip (?) When there is no obstacle, the lora base rover I have is flawless. Of course, that is not reflective of reality specially in areas with lots of vegetation and rolling/steep terrain. In the presence of cellular signal, the next best thing to lora is the use of ntrip. I tried using m2 as base and emlid caster to send correction but somehow the correction is not picked up by my RS2. I followed instructions at Emlid. Can you share the exact hardware/software/workflow you have on the base side. Thx.

1 Like

Ive found lora is good for about 1/4 section reliably.

I am editing a video about this topic now.