AgOpenGPS v 5.2.1 Bugs

Should be getting pretty stable - but there is always something missed. Please post any bugs you find and we will stomp them out.

1 Like

Brian ,Aog Teams thanks to improve and improve

i do test of V5.2.1 this saturday during harvesting and i find small trouble

after defined a AB line
if you recenter with the screen button
and after you try to acces to " parameter of the AB lin"e to see but not modify
if you left this screen with out saving you will loose your recenter line and you return to initial setting of ab line ( so need to be save as temporaly )

During usage autosteer
if you acces to gear parameter evry time and you left the menu the IMU filter was reset and the position is crazy during few second ( Is it possible to keep filter to be more smooth?)

if it is not clear i will take a video

  1. There are 3 choices when leaving the edit ab screen, so pick the one to save if you want to save it, cancel or return to original saved. So you need to push this to ignore…


  1. i’ll have to check that

Not sure what the cause is but I was setting up another new tablet and every time the keyboard was opened to enter something a error poped up, so hit continue and the keys are all messed up.

So thinking what I did last time around I installed v4 with the windows installer it uses, then deleted v4, reload v5 and it’s away perfect :thinking:.

What would cause that drama?

What was the error?

I had exactly the same error on one of the tablets.
This may have something to do with the language change, the problem arose after turning on the translation, but maybe it’s a coincidence.

Well thats my rookie mistake I didnt screen shot the error.

It was like Null Reference Exception and Keyboard was in there. As if it didnt know how to put the keyboard together, if you clicked continue the keyboard would open put had all sorts of funny buttons.

Next time I will screen shot / copy the error.

What is the diffrence between v4 using the installer (whatever thats called), and v5 just unzipping the folder?

Not a lot of difference, its one of those “what the heck are you doing Windows” problems involving culture and keyboards etc that are nearly impossible to fix - only luck to stumble across it in the right combination

Has anyone tried the raise and lower function?
I Played with it in simulation mode, no UP or DOWN arrows are popping up and no relay is triggered. Hydraulic lift is turned on. Headland and boundary created as well. Tractor turns around fine but but no sraise and lower. That happens on all laptops.



I can’t get the “line jump” to work. It just wiggles when I push the icon, then continues on the same line. It does not move to the next line. If I press eg. 3 times the purple line moves 3 lines over, but jumps right back to it’s original heading. It may be a Windows upgrade related problem. It worked when I installed it, but after I was messing around to get the led lightbar to work, AGIO kept freezing when I tried to change com port settings. So I re-installed everything. Now the external lightbar works, but the lateral line jump does not. I am aware this might be my own doing and not a bug, but it’s not easy dealing with this stuff when you have a mechanical brain.

Possible to make a little video of what is happening?

Since the problem occured after I connected the external lightbar I tried disconnecting the ext. lightbar and re-starting everything without the ext. lightbar connected. Now it worked flawless. When I re-connected the ext. lightbar the problem came back. It seems the problem is the code for the ext. lightbar. I have enclosed a video of the problem.

That is really strange because the code in AOG is the same whether the lightbar is connected or not. That lightbar byte is always calculated. this is kind of confusing.

                if (guidanceLineDistanceOff == 32020 || guidanceLineDistanceOff == 32000)
                    distanceX2 = 255;

                    distanceX2 = (int)(guidanceLineDistanceOff * 0.05);

                    if (distanceX2 < -127) distanceX2 = -127;
                    else if (distanceX2 > 127) distanceX2 = 127;
                    distanceX2 += 127;

                p_254.pgn[p_254.lineDistance] = unchecked((byte)distanceX2);

The lightbar code is always run, the pgn is sent with the lightbar data etc whether it is connected or not.

Do you do anything else when lightbar gets connected?

Thank you for your response.
The lightbar uses an Atom Lite without battery, so it’s powered by an USB-kabel from the PC. The communication between the Atom Lite and Agopen goes via an external USB Bluetooth-adapter named COM5 in AGIO. My PC don’t have Bluetooth built in. Maybe I should try to power the Atom Lite from another power source to rule out interference? It will have to be tomorrow. It’s after midnight here.

Solution to my hydraulic lift issues = when you enable hydraulic lift you need to restart the program…
That was easy.

yes, give it a try. So you are using your own code?

It is a bit of a bug, you need to turn off headland off and back on again for the Hyd button on off to show up. Turning the hydraulic lift on or off in the Config / Arduino / Machine page only controls the arduino behavior.

Edit: I fixed the button not coming up. Will be in 5.2.2 shortly.

1 Like

Thanks to modify for Hyd button
I consider on the past as safety but now it will be more easy

small issue in keyboard (more complex to solve) when i try to rename AB line if i miss a letter … impossible to add letter in the midle so need to erase and restart …

1 Like

Since it is a file name, there is a lot of character checking to make sure windows doesn’t freak out when you go to save. It isn’t a simple text field unfortunately.

One more thing to figure out how to make it more user friendly though. Thanks!

1 Like

Tried external power. Same result.
I found this code on the forum in the thread «External lightbar»

I have modified the number of leds and cm per led in the code.

I should add that I have only tested this version in simulator yet. And since I don’t have autosteer in real life I can live with this bug. I just wanted to let you know.