Arduino teensy 4.1 problem

Hello, I use all in one V2,5 board. First time I connected everything together arduino orange
led light was up, or it was blinking, i can’t remember correctly. I tried to push buttons on the cytron md13s to run motor, is it possible I destroy teensy 4.1 after this? I messured voltage on PCB it’s 5V everywhere like it should be. BN08X is not working, because it’s not have 3,3V from arduino. I tried to connect arduino to PC (after remove from PCB) one time little red LED light was blinking, but now nothing comes up. What I do wrong here?

Using the buttons on the cytron should not hurt the teensy. How were you powering the board? If you open a serial monitor on arduino ide and under ports select the teensy port. Does anything come up on the monitor?

1 Like

did you upload the code to teensy? :slight_smile:
look for v2.5 firmware: Configuring The Teensy · farmerbriantee/AgOpenGPS_Boards Wiki · GitHub

1 Like

Yes I did. The problem is now my computer don’t find teensy anymore. Will try new cable, maybe this is problem.

Nothing happens, I will try new usb cable. And will buy new arduino, because if first auto steering project will work, I will do another for my second tractor :smiley:

Try a full factory reset of the Teensy (which will automatically flash the Blink sketch) before you do anything else.

1 Like

Thank you! I tried this and something happened. Now Tennsy RED LED light is blinking first 4 times then 2 times and now BNO08X has 3V and the green light is on, light is on and on the ethernet port. So now I need upload the code to Teensy again?

it should be blinking constantly if Blink loaded, but yes, upload again

1 Like

and V4 needs V4.1 firmware and V2 needs the V2.5 firmware!

we have 2 kind of enclosures based on the phyiscal size, and 2 firmware based on the version (pcb layout)

1 Like

Thanks to everyone for responses, very nice community here!
Now I tried new Teensy and new micro usb cable and now new Teensy works like it’s shoud. But old one is still has blinking RED LED light and doing nothing, I still can’t connect it to my computer. Now I need again check my firmware do I uploaded righ one to my new Teensy and only then I will try to connect it to my PCB.

Thanks for imformation, I will try to see if I chose right one.

Aren’t they both almost identical except for the uncommented line in AutosteerPID.ino? I have run both firmwares on both boards and never had an issue.

Today had little time to play :smiley:

New Teensy, when I insert it to PCB, RED LED light is blinking… Ethernet port green and orange lights are up, but no connection to my laptop ( now I use real cable, not adapter to USB). No network is showing up, just my wi fi. If I connect only Teensy and do serial monitor I have this message:

The red light shouldn’t be blinking on the teensy. Should be an orange light flashing
Have you got the ethernet pins in the teensy and the pcb?

1 Like

Yes I have, but it’s home made from standart arduino pins, tomorrow will try to test contacts with multimeter. Or maybe I need to change something in arduino coding, because I didn’t change anything.

Are you using a crossover Ethernet cable or just a standard one?

1 Like

Are you powering the PCB properly? The WAS 5V regulator needs the PCB 12V.

1 Like

This is my cable, I think it is standart one https://www.amazon.de/-/en/Ugreen-CAT7-Flat-Ethernet-Cable/dp/B088G2M583

Yes it has 12V. If I messure arduino have 5V input from PCB.

Hello, do you have 3.3V on the Teensy pin ?

You mentionned earlier that you lost this 3.3V, did you recover it on the old Teensy after factory reset ?

I had a very similar issue where, in operation, the Teensy lost its 3.3V, so the BNO had no voltage supply too. I had to change the Teensy. I did not try Factory Reset but I am curious to see if this would fix the issue.

2 Likes