Ardusimple F9P Ethernet connection

So I want use AgOpen auto section control with our current rate controller.

Just have an arduino for machine control with ethernet that is functioning with ethernet.
But I can’t seem to get the Ardusimple to work over ethernet. I’ve downloaded several Ardusimple files from here, but I’m not sure what exactly they all are and am not sure what to all look for to make it all work. I think my issue is my network adapter but not sure.
So does someone have a known good file for the ardusimple that I can use to eliminate the ardusimple as my problem?

Thanks

How is it connected to ethernet?

TP-Link switch

TP-Link Switch

Ok but how are you getting the f9p to the tp link

Sorry, lol!

USR-TCP232-E45

Have you followed this thread?

Yes. I’ve gone through it several times. I’ll try and post some relevant screenshots. This thing has a slightly different UI than the one he is using, and that, together with the language difference and me not quite understanding the whole UDP idea is throwing me for a loop.




The computer gate way is on 158 instead of 168? Looks good otherwise

Welp!! :confused: Not sure how I missed that.
Fixed that, restarted everything and… still no dice.

try with udp in client mode and disable simulator mode

Have you set the f9p to output messages on all ports in u-center CFG?
Like in this post about C099.:
Good morning
with a little patience and reading various posts I reached my goal !!
Connect the C099-F9P to the Tablet via blootooth and everything works, even the problem of agopengps version 5.2.2 solved.
All NEMEA messages must be disabled from u-center: except nemea GxGGA, and nemea GxVTG.
u-center> view> configuration view> (item) MSG (messages) scroll the items and deselect all the boxes and at each item press the send button at the bottom left.
To store all select CFG (configuration) and with the control key pressed select all the items in the device window (0-BBR, 1-FLASH, 2-I2C-EEPROM, 4-SPI-FLASH), then send button.
With this procedure I can communicate via bluetooth and everything works correctly!
I hope I was helpful !!!

2

Jul '21

How you wire ardusimple and usr TCP ?

Well, another newbie move. I guess I forgot to disable the sim. I know I had it off for awhile, but I think I turned it back on to make sure my machine module was still working.

And I don’t think this thing has "UDP client” mode.

And I will check the rest of the suggestions this evening.

I have it wired like the above linked thread

Ok, so more tinkering here. Still no go. Can’t seem to get anything reliable with USB either. Anyone have a file that definitely works with usb and/or Ethernet?

Or any other ideas?

Do you get a fix when connected via ucenter

So, “fix” as in the GPS is getting my location? Yes. I’m not connecting to RTK, so no RTK fix.

So last night I reloaded the Ardusimple file I was using, plugged the USB into Agopen, and it just started working. No clue what changed. But still no Ethernet.