F9P in ethernet mode

To use the simpleRTK2B or simpleT K3B card in udp mode, it is possible to add a serial UART TTL to Ethernet converter module such as this one
https://www.pusr.com/products/serial-to-ethernet-converter-modules-usr-tcp232-t2.html
or if you want to connect 2 serial port this other TTL to Ethernet Modules | UART over Ethernet Modules
The 1st step is to configure the ardusimple card
follow this link if you do not master the procedure
F9P firmware update and config files
it is necessary to transmit the desired nmea frame and receive the rtcm3 correction by the uart 1 to 115200
you can use the attached configuration file for the fw 1.13
RTK2B_FW113_Rover_10Hz-rs232-bt- .txt (20,9 Ko)

you can use the attached configuration file for the fw 1.30
TERV-RTK2B_FW130_Rover_10Hz-uart1-uart2-gga vtg.txt (25,0 Ko)

this operation completed connect your tcp232 following the attached diagram


Your assembly finished, connect an antenna, place it outside with a clear view to the sky.
Power your cards as shown in the diagram and connect your computer with an ethernet cable to the tcp 232 module
to access and configure it you must enter the address 192.168.0.7 in your internet browser with the username ‘ADMIN’ and the password ‘ADMIN’
Disconnect your network card and use local connection.
to connect the module directly to the PC, you must define a static IP address for the computer in the
same network segment as the module. for example 192.168.0.10

once connect to the module define the parameters so that it corresponds to your configuration here I left in static ip I just modify the ip address so that it corresponds to my segment network

go to serial port setting

save and restart the module

close your browser and restore your network settings then start AGIO
you need to disconnect the com port if it is active, enable udp and set the ntrip port to 8888 and get the following pages

according to the same principle we can use the usr-tcp232-e2 module which manages two uart thus making it possible to put the gps card and the pcb in the same box with a single rj45 connection, however, be careful with respect to the 3.3 v for the ttl signal

16 Likes

Great share, I did this 2 months ago and took 1 day to run it :slight_smile: If I hadn’t I would have bought the TCP 232-E2 model. Thanks.

I tried and succeeded with the same components to have NMEA over UDP. Also works with wifi connection.

When all components are connected to AOG via UDP, it would be fine to have a central control room to operate various machinery totally remotely over internet and fixed IP addresses or Dynamic DNS services.

With fully CAN-based setup at the tractor/machine/rover end, it would be possible to have also a full manual control equipment at the remote office. Valtra, Caterpillar etc. are already offering such remote cabs to use with their more modern machines.

I could imagine sending out a machine, doing certain things in full manual control and then letting the machine continue in full auto mode. Then move on to set up the next machine and so on.

Total dream would be to have full 360 degree camera setup at the machine and do all that with VR-glasses. If the machine happened to be an electric “jet” plane/copter with good range and high resolution multispectral cameras, that would make it possible to do field scouting maybe within 10-20 km range “in person” with VR-glasses and full manual/auto controls totally over 4G :heart_eyes: Shame that legislation is trailing far behind.

there is also the https://fr.aliexpress.com/wholesale?catId=0&initiative_id=SB_20220106045722&SearchText=USR-TCP232-ED2 which is very interesting

Hi :slight_smile:
Thank you for this nice tutorial! I connected my F9p with USR-TCP232. I was surpriced because it worked from beginning without nearly any problems. But then i have seen 2 strange things:

→ The data refresh is very slow. It looks like maximum 1 Hz sample rate. I am not sure if this is fast enough for steering. Connected with USB it is much faster. Is there a way to accelerate this?

→ In the system data window i am missing the VTG-Data. GGA is working fine. It looks like the USR is cutting it away. Without i have no speed.

Had anybody the same?

best regards

in ucenter MSG you can set where to send GGA and VTG . In your config vtg should be sent to uart1.

1 Like

Thank you!
This helped! UART1 was not activated. Now the VTG Data is sending data like 10 Hz. I also have seen that the GGA-setting at UART1 was 10 which was the reason why i got only 1 message per second. Now i changed it to 1 and i have 10 messages per second.

Thank you!

1 Like

Have you got it to work on 5.62 with ntrip? I had to go back to 5.5 to get a constent correction. 5.62 would only update every 100-150 seconds

https://m.facebook.com/groups/293313775751826/permalink/557736715976196/?sfnsn=mo

i tested it with 5.62 and more it works very well however it is preferable to avoid port 8888 for the ntrip there may be delays in the correction but with the port on 2223 it works wonderfully

Ahh ok. Ill try that today

Changing the port fixed it. Thankyou

Pinned nice work :ok_hand: :ok_hand:

OK @Vili

So do you think the F9P on UDP is fast enough to pull off the PANDA trick without having to solder the gps and teensy directly together?

This would allow a tiny pcb like the CAN group is using to do everything except physically steer.
Then the cytron could be mounted directly at the steering wheel on udp for phidgets users.

I am seeing the UDP move as a way to make every item modular on the network. If you want to make future upgrades, you just replace one UDP connected module. Like if you changed to a different GPS manufacturers receiver it would only require network access for the one item to integrate into the existing installed AOG system.

I think it may be, but you will almost certainly have to adjust the delay on PANDA ino (test needed for better results)