Base/Rover Configuration in U-Center


I assembled an AOG system last winter and used it one season but wasn’t able to get RTK to work. I’m trying to use a SimpleRTK2B with a WiFi NTRIP Master as the base through RTK2GO. For the rover, I’m using a SimpleRTK2B connected to the PCB V2 via a TCP232 Ethernet shield.

Does anyone have compatible base and rover configuration files for this setup?

Connect to pcbv2? It should be connected to tablet.
For base you got config hire:

For rover you can use single antenna config in board repo.

Thank you! Yes, sorry I meant connected to the tablet. I mounted it in an enclosure with the PCB V2 and an Ethernet switch.

is your base showing up on rtk2go?

I had it showing up with all the correct messages but then the messages disappeared after I changed the configuration. It still shows up but I definitely don’t have it set right yet. I will test the new configurations this weekend.

start at the base then

I’m working on the base right now. I uploaded the base configuration you linked and it looks good in U-Center but it doesn’t look like any messages are showing up on rtk2go.

Does ND not have a free CORS network like many other states?

It looks like the nearest CORS base is over 50 miles away so I don’t think it will work. It would be nice if that were an option though.

This u-center screen does not show how the receiver works as a base. It just shows the receiver is sending many NMEA messages but those should not be sent to RTK2GO. You should open a message view to capture a sequence of RTCM messages and hopefully those are sent over the port that the WIFI NTRIP master is listening.

Thanks. I’ll give it a try. Do you know what port the NTRIP master would be listening to if it’s plugged into the Xbee header?

The xbee header is uart2


I’m sorry if this is a stupid question but what should I look for in messages view? RTCM 3 is completely greyed out if that’s it. I looked at the packet console and it’s just NMEA messages. Where do I go to see RTCM messages?

I set up the same system you are making a few weeks ago. You are in the right place but instead of all that stuff you should see rtcm 3 messages only.

you are showing up on rtk2go but without any messages so the ntrip master should be set up right. you need to turn on the messages you want on uart2 and turn off all that other stuff. seems to me you can go to the messages window and right click on nema for example and you should get a option saying disable all messages or something like that.

1 Like

Thanks, I’ll try this tomorrow!

Hi, I was able to disable NMEA messages exactly like you said and now the packet console is completely blank. Where do I go to enable RTCM messages? It looks to me like they’re already enabled but they’re greyed out in messages view.

I see you are still not showing data on rtk2go. I’m trying to think what else could be wrong.

Are you surveying in or using fixed coordinates? I know for sure it doest send 1005 messages (and maybe the other ones as well?) till you are surveyed in.

Maybe the baud rate of the f9p doesnt match the ntrip master?

I think you have to enable rtcm3 messages for usb as well as uart for them to show up in ucenter. not necessary for it to work so that is not your problem but it will help with troubleshooting.

I used this following post when i set mine up. It might give you more ideas of things to check.


Dec '22

Here’s how I configured my base station ZED-F9P. There are no doubt other variations people use. I’ll look up your radios and see what they need a bit later.

  1. launch U-Center and connecting to the ZED-F9P, select “View->Configuration View”
  2. select PRT (Ports)
  • Select Target UART2
  • Make sure Protocol out is “5 - RTCM3”
  • Set baudrate to 115200 (the default for your radio modules)
  • Click “Send” button
  1. select MSG (Messages)
  • For each of the following message types, select them in the “Message” drop down box, then make sure UART2 is checked, and put the number listed in the input box next to the check box, which specifies how often to send the message. Note that for other kinds of roving receivers there might be a different set used. But for ZED-F9P rovers, MSM7 works nicely and you have enough bandwidth on those radios for all of this. Other radios (including Lora) might need a reduced message set
    • “F5-05 RTCM3.3 1005” 10
    • “F5-05 RTCM3.3 1077” 1 — GPS observations
    • “F5-05 RTCM3.3 1087” 1 — Glonass observations
    • “F5-05 RTCM3.3 1097” 1 — Galileo observations
    • “F5-05 RTCM3.3 1127” 1 — Beidou observations
    • “F5-05 RTCM3.3 1230” 10 — Glonass code biases; not sure if this is required for any modern GPS receiver
  • click “Send” button
  1. Select “RATE (Rates”
  • For each time source in the drop-down box, set measurement period to 1000, set Navigation rate to 1 cyc.
  • This will set the base message rate to 1 per second, which is what you want for the RTCMv3 messages coming from the base station
  • click “send”
  1. Select “TMODE3 (Time Mode 3)”
  • If you want to do a survey to find the average base station coordinate, select mode “1 - Survey-in”). This can be changed to a fixed location later when the base station is permanently mounted
    • Set the minimum observation time to at least 120 seconds
    • Set the Required Position Accuracy to 1 metre. You can make this finer but honestly it doesn’t need to be. RTK is all about relative accuracy, not absolute.
    • Click “Send” This should start the survey process. See step 7 for how to monitor the process
  • If you want to set the base station location (perhaps using Google Earth as a reference), select the mode to be “2 - Fixed Mode”
    • check the box that says “Use Lat/Lon/Alt Position” if you have coordinates in that form from Google Earth
    • enter the latitude, longitude, and altitude in the fields, or if you’re trying to make a survey-in permanent, enter the ECEF coordinates (see #7 below)
    • click “send”
  1. Save settings to flash very important
  • Select “CFG (Configuration)”
  • Select “Save current configuration” radio button
  • Select “0-BBR” and “1-FLASH” under devices (should already be highlighted)
  • Click “Send”
  1. How to monitor survey-in process
  • From main menu select “View->Messages View”
  • Find “UBX” in the list and double click it.
  • Select “NAV (Navigation”), “SVIN (Survey-in)”
    • click the “Poll” button to refresh the information.
    • when complete “Mean Position Valid” field should say “Yes”
    • can use the the ECEF coordinates as a “Fixed Position” in step 5 above to make the base station position permanent.
  1. Download configuration file in case you need to set up a new base station later
  • From the main menu select “Tools->Receiver Configuration”
  • Set the file name you want
  • Click “Transfer GNSS->File” button
  • Can upload a save configuration with the “Transfer File->GNSS” button

Thanks for all the great info. I’ll try those steps when I get a chance. It’s definitely possible that I wasn’t doing the survey-in process correctly.

I got it working. Seems like the problem was the baudrate on the Ntrip Master. Also looked like some of those RTCM messages were somehow turned off. I’m leaving for about a week now so I set it to survey in for 5 days just because I can. Thank you so much for all the help!