Can't get a green Gps light in agio or on board

Hello all, thanks in adavance for any help. with planting getting near starting to stress…
I have checked the forms for solution. heres the issue, forgive me I’m not overly techy. In agio i cannot get a green light on the gps logo. imu and steering are green. followed lansolat guade and used his tool and have also tried manually configuring manual the f9p.

i have two board (v 4.1) and two of everything bassically. teensey f9p tried swaping all combinations
and nothing. verified its set to uart1 at 46800 I will upload pictures once i can resize. have a base station working. but also only getting 3 lines ove correction and no more after is that normal aswell… thanks in advance for any help!

How about the gps light on the f9p itself? Is there power to the f9p? Maybe explain more about what you mean by 3 lines from your base station as well

Edit: davidwedel has a good idea. See if you can isolate the problem to the f9p or the board.

Any chance you could plug the receiver into AgIOs serial monitor and make sure it was getting GPS?

1 Like

thanks so much for response. i should have mentioned I’m using the micro F9P
please see attached pictures maybe somebody will see something I’ve missed

sorry for delay had to learn how to resize pictures.

I’m not 100 percent sure I know what you mean by plugging receiver into agio serial monitor? sorry I’ve been lurking on here for a few years but still learning.

did you uploaded right software for GPS ? check the Arduino ( connect Teensy be USB with PC ) program to see what it shows on the monitor if there will be Swapping GPS port if I am not wrong this will mean that he is waiting for the GPS and it has the wrong software loaded

1 Like

Described there.
@Lukasz is suggesting the same thing as me, except he suggested watching the teensy instead of the receiver.

To talk to the f9p you have to plug it into the correct USB I don’t think the two are linked.

1 Like

Where is the antenna?

Talk us through everything you’ve got, and done.

You said you used my guide - but I don’t see what you’re trying to drive. Is it a motor? I see no Cytron, so I’m presuming CANBUS. Why the cut power cable and what’s the USB doing in the unused port?

What’s wired to the tractor in terms of WAS and steering, and how?

Which firmware did you use?

There’s no such thing as too much information… but there is too little. If we know the above, it’ll be cleared where to advise.

Thanks for all the help.

So I started building the boards last year micro board V4.1.
the plan is to drive a steer motor 24v using cytron had it removed from the board for the picture. (I cut power cable because the solder joint on one side failed and i need to fix.)
the usb is plugged in the unused micro port because if i keep unplugging them i pull the mounting out of the board so i just left it. ( i was putting the fp9 there just to program)

I am only bench testing so far. I have (i think successfully) set up a base station using the standard size f9p and an Pi with outdoor antenna. broadcasting using rtk2go.
I do have 2 f9p micros (plans to install on 2 tractors eventually that’s why I was building two of everything. which is great for swapnostics.) i do have the antenna hooked up and sitting by a window. i have had success with seeing satellites doing this using u-center.

the tractor so for just has a wheel angle sensor (a john deere position sensor. (I’m a JD tech just what i had) and the steering wheel motor mounted. but I haven’t hooked them up yet.o

I used the agconfigomatic to update the flash teensy and the f9p and set config. I connected the f9p to the aog board and powered the board to do this (the micro has no plug)
firmware was 1.13 also used 1.13 when I tried to do this manually through u center and push the config file to it aswell (and saved) and i get same result if i use configomatic or do it manually on both f9ps. in the configomatic i used the v4.x board option to config teensey. haven’t tried configuring that manually.

I’m going to post pictures here in just a min to show what I’m seeing in I belive the serial monitor which someone asked about. this is where i start to get lost.

Ok so tonight I unpluged the ethernest adapter (usb to ethernet) from the board and pluged the f9p usb (correct one) into the toughpads only usb port. (see pics) pulled up serial port and can connect on com 3 see more pictures

I think this is what @lukasz and @davidwedel were after. if not please let me know

Yes. Looks like the receiver is working. Try connecting to the teensy USB, and watch that on the serial port.

I can not get a strong signal inside a building. For the development of AgIo i use an emulator.

1 Like

I have tried connected to the teensy and only recive mesage “swapping gps ports” over and over.
I’ve attaced a picture of it and teensy.
I assumed teensy was working because I had green lights on imu and steer. maybe they dont go through teensy?
I’ve also attached picture of my teensy. I had to put a spacer bridge to make the smaller 6pin bridge reach the ag io board. not sure if eveyones is like this its been a while since ive assembled this part of the project.

if Teensy is not connected to the board and you only connected it to the computer via USB and you will get a message “swapping gps ports” it just waits for GPS, to have an active GPS module picture of the antenna in green you do not need to have an antenna connected to the GPS module

however, in this picture you can see that Teensy has connected to GPS and is getting parameters, so I don’t know why your GPS module is not lit in green, maybe a different IP address?..

Check the soldering joints of your teensy, may be you have problems with cold or bad joints. (teensy seems not soldered properly) Check the required connections to beetween f9p header and teensy header with an ohmmeter.

thats a good idea. where can i find a schematic or something to show me which pins interface with each?
will try this tonight. also was playing with trying to change ip address/ but how do i get agio to change the subnet so I can match?

1 Like

so I watched the fideo and i tried playing around with diffrent ip address with no sucess. was checking connections on teensy and f9p with ohm meter and then I had an idea. if i had more usb ports could i use one for ethernet and one for the f9p? they both worked in serial monitor. I have a usb splitter? so i plugged that in and plugged both f9p and ethernet in (see picture) and it worked!!

Is it ok to run like this? Im happy to use as is untill I get planting done.
also im not getting a solid green light for rtk. it switches between green and red? does that indicate float? is it possible my antenna (infront of a window) isent getting enough signal to get to rtk?

Thanks everyone for your responses and help.