Cant get RTK to connect

Hi guys I cant seem to get a RTK connection
I am using V5.6.2 UDP for Steer and IMU and USB for GPS and Im using my mobile phone USB tethering

for internet using Auscors Ntrip this is a photo of what I can get but unfortunately I cant get RTK any Ideas? Thanks Viv

Open a command prompt and in it type

netstat -ano | findstr 2101

You should see a line mentioning the outgoing connection to Auscors. If you don’t, it means you’re not connecting through your phone quite right.

Try changing https from 1.1 to 1 in the ntrip menu in agio. Think its on the advanced tab

The old Auscors url is no longer available. Have you changed to

Sometimes I get a patchy connection, and I’m not sure if it’s the phone, tablet or caster. Restarting everything usually resolves it, or mashing the confirm IP and bringing up the mount table gives it the right motivation.

1 Like

Thankyou I changed it and it worked. It does seem to be a bit slow as I turn on the headland tractor icon is a bit behind in turning. Also the speedometer shows I’m doing 32km/h when I’m actually doing about 4km/h not sure what the issue is .

Yes mine today seems patchy too I was blaming poor mobile service but not sure yet I’ll have a bit more of a play

What config are you using? Is it running on 10hz?

Here’s a tip on how to find out if it’s a connection issue - download TCPView here TCPView for Windows - Windows Sysinternals | Microsoft Learn

Run it, and type “agio” in the box at the top as a filter. The line you’re interested in is the “Remote Port” with a value of 2101 (unless Auscors is different?)

If your connection is having issues, then you’ll keep seeing the bar go red and green as it tries to contact, or re-establishes contact with the NTRIP server. If it stays on Established and the Local Port number doesn’t keep increasing, then you have a stable connection (which in your case then, might imply the auscors service is perhaps having issues). In my case, I’m connecting to rtk2go here, but the reverse IP of that is Amazon hence the weird hostname.

Awesome thank you Ill give it a try

I had this issue using rtk with version 5.6.2 . I think there is a known issue with the AOG 5.6.2 release and speed calculation. I am using PANDA but i don’t think it is related to that. I’ve upgraded to 5.6.15 and reenabled VTG message from the F9P

Ok sounds like I will have to upgrade to the latest version thanks

Are you using Panda if so there are some changes needed to the panda ino as the latest version is a pre release.

No no panda

Hi again I upgraded to V5.6.14 uploaded firmware to and configured the f9p
and now I have lost RTK not sure what is wrong but I can still access satellites on Agio as per the photo and I can also get an IP address when I Confirm IP .

Any ideas thanks?

That all looks good its receiving corrections allright. How many satellites is it picking up? Is it getting float or dgps?

It usually gets 5 or 6 but I have had up to 10. It says invalid where before when it was working it said rtk fix and showed lat long and showed messages in the GGA and VTG boxes

And here are my Ntrip Settings

Hey Andy I tried that and it came up with and stayed on yellow