Danfoss valve

AOG pcbv2 with Danfoss valve and ibt2
I have checked my voltage from the ibt2 in drive, and when I move the slider in drive the voltage goes from .25 to .75 as I move the slider from side to side.
When I connect the valve, and engage, it turns the wheels all the way in the direction the wheels are setting from center. Move the slider in drive and nothing. Disengage and manually turn the wheel back close to center, and engage. Same thing.
I have checked my wiring against the schematic and everything seems good. Even changed the valve head out with another and it does the same thing
Any ideas ?

Do you have any way to scope the PWM signals?

Which AOG and ino version are you using?

You must search for Danfoss at the top of this page. You should find more information on ibt_2 and Danfoss.
It is. 25 and . 75 % of input voltage. So if 12 v it is 3 v and 9 v
At 6 v it should not move.

No, just multimeter

I am using 4.1.12 I think. It wouldn’t do anything on 4.3. I did switch 5 and 9 in the coffeetrac button ino and used the pwm2 .

P.S. for Brian. V4310 is great. What are the chances of getting a version of it but with pid as a valve version for all the guys with autosteer ready tractors ? I really have enjoyed it and hated having to go back to an older version when I switched to danfoss valve.

1 Like

I have 12.54 v at m+ . Isn’t it on m- in the diagram.
3 to 9 is coming from m-
This is the ino from coffeetrac I downloaded a week ago.

Diagram is wrong at that point . Someone else already burnt his ibt_2

But that was not what you asked: wrong diagram have wire for B+ and B- switched
So question is: do you use diagram from coffeetrac or support folder?

I used what kuopoi put on ino for pcb+md13s+danfoss

After reading the voltage, I connected the m+ to Udc and m- to Us
Len and Ren on pwm2 switched 5 and 9 in ino
Lpmw from drive to pwm2
Rpmw to dir pin on pcb2

Correction Lpwm to pwm1

Okay, after a pounding headache, due to my own ignorance, it’s working fine. I thought the reason its turned the wheel all the way was because steer direction was backward, causing aog to increase pwm.
I was right. But I changed the direction in aog, not realizing it wasn’t changing it in button.ino. changed steer direction in .ino and everything works fine.
Knowing what to adjust to tune is a whole nother matter all together.

As one of the many farmers who have been frustrated at the autosteer providers to the point madness.
I want to thank everyone who has worked selflessly to provide AOG to the public. Thank You

Got it steering straight and close with drive button as Brian suggested. Took to the field for a little adjusting. Seems to hold the line decent, but the roll is reading x and I need y. It is v4.1.12. Chose y in module and restarted. Doesn’t change. Also need to invert, but it doesn’t change.
Looked in the code but can’t find anything in there to fix it
Also, with GPS disconnected my button triggers 5 to 7
Connected when I toggle it, I get a quick 7 then back to 5
Tried holding the button down like a switch but it still goes back to 5
I know it’s the coffeetrac button.ino but i don’t understand why it will work with the drive only connected
Do i need an older version of aog ?

You can not change /upload things from the new versions, that demands the Autosteerpcbv2.ino, but I believe it will work when set in button.ino, and manually uploaded to nano
In vehicle settings in v4 you must also set to remote under guidance, and the button should work!
Or go back to 3.09
I believe this is the line you were looking for:(far down I searched for roll)

Thanks Lars
So I set the x to y
Do I switch the negative and positive on the 2 lines below it to reverse the roll ?

Sorry, I forgot there was a line to invert in the setup
Changed to y and inverted.
Turned the remote switch on. I thought that was another place to engage for some reason.
Anyway, thanks again it’s working great

I have a question for those of you who have set up a system with a Danfoss Valve…

Final step in my setup was to connect the Danfoss Valve. Everything else seem to work the way it’s supposed to. So far I’m only testing “off-tractor” in simulator mode. Danfoss-setting is activated in AgOpenGps.

I’m using Kaupoi V4 with Cytron MD13S. (no WAS connected to the board at the moment, don’t know if that matters…) Danfoss Actuator is a PVEA series 6. Cytron is connected to Signal Pin (Vi) on PVEA, Spool position pin is not connected to board.

With autosteer off PVEA is blinking at 1hz, as it’s supposed to. When I turn autosteer on it starts buzzing. And the green light is still blinking as if it was in stand by mode.

Is it working as it’s supposed to? Perhaps that buzzing sound is just normal?

With no WAS connected, you probably have a large angle error, so when its engaged, it is it is calling for max pwm to correct. In drive see what the pwm value is. It would seem normal to hear it buzz since it is at full pwm. Just a guess. I have never tried one except on the tractor. If it’s a good valve, I would install it and see.

I have mounted a pvg16 with pvea-ci actuator on my new holland. I had that buzzing sound when i first started the valve without starting the tractor so there was no pressure on the valve. It also stayed in stand-by mode.I think you get that sound when the actuator is “dry” running. After the first start with pressure the valve worked well.

1 Like

Perfect. Then I’ll mount it and try again.