Ethernet Connection not working - V5 board


I was handed a bag of bits, and managed to assemble them into this.
Carried out all the safety checks with PSU before mounting the boards, and traced through the voltage lines, 12, 5 and 3.3. Then programmed the Teensy and the Blox devices also added the configuration file. (I’ve been mending electronics bits and pieces for years, so have managed to keep the smoke inside, so far…)

I don’t have a GPS antenna or Cytron to play with at this time.

On power up, all the boards light up. I get the AS-ACT lamp on for a second or so, then the other two, so the three big LEDs all on and RED.
I also get the LED in the middle of the Teensy pulsing. (I don’t know if this is normal or not.)
To connect to the unit, I am using a W7 laptop and have installed the AGOpenGPS software and also the Teensy Serial port driver.
Running AgIO in USB mode, there is nothing being read, which I guess would be normal without an antenna.
Have then tried to connect via ethernet, using a 12volt PSU onto the AmpSeal.
In W7, have set the laptop IP to and mask as in the on line guides, and AgIO enabled the UDP and manually set the 192.168.3 mask. Sadly in AgIO although this address is in the list, it is not UP.
In fact the laptop states that the adapter is unplugged. Tried more than one cable, and this port on the laptop is fine connected into a switch.
The RJ45 socket has one green LED on.

I’d appreciate some guidance on looking into this please.

I don’t see your teensy ethernet pins soldered(6 holes in the middle of teensy board)

I also couldn’t find those header pins because I think they are smaller than the ones on sides(smaller pitch/spacing). So I soldered utp cable between teensy and board and it works for me.

Also, its written on gps receiver that its not recommended to power it without antenna…

The pins on the side have 2.54mm spaceing, the 6 smal pins for ethernet have 2mm spaceing

1 Like

aha, the Teensy ethernet isn’t connected, well that would explain it.
Thank you.
I cannot see anything written on this gps, either side, re must have antenna connected, but sounds like a sensible idea, will take note.

1 Like

Yes, my point exactly :slightly_smiling_face:

Ok, thank you.

I was sure I have read it somewhere but now I don’t see it haha

This is what I was talking about, at my place I couldn’t find pins that size so I had to do it this way

It works in a pinch to just pull the pins out of a normal header and use those without the plastic support.

1 Like

This is the pair i use

Edit: Now with correct links

1 Like

Thanks Guys. the Digi-Key bits in the UK have to ship from the US, so its 4 days and £22 for ten which is ok if doing a number, but I have a plan now based on extracting pins from other headers I have. Will report back.

Bullhill and Guy100 hit the nail on the head.

I measured that the pins ideally need to be 13mm long to get half a mm or so proud of the surface, but the standard 2.54 header is only 12mm.
So, inserted flush, the stand out underneath is 10.2 and ‘at a pinch’ that’ll do.

Proof is that it runs with Green Ethernet/Power LED.

Thanks to you all.


Are these cross-compatible with the ones listed here?

(on the picture your header looks a bit taller)

Or yours require only these 2 pieces instead of the 2 header + interconnect?
Price-wise it’s pretty much the same though.

The board was partially assembled when I was handed the project, and a socket header like that, not in any of the images above, was mounted on it I guess when it was float soldered with the surface mount components.
So my pins soldered into the Teensy push into that header.
But yes, mounting another to the underside of the Teensy would have also been an idea, but then the pins I pulled out of a 25.4 header might have been a fraction too long to make the connection between the two. However when removing the Teensy in the future, there might be a question about where the pins stay, in the board header or the Teensy one, or maybe even fall out.

I dont have female headers on both sides. I only use one of each.

Ok, I misunderstood.