FZ-G1 ethernet controller not working


I thought to ask about help here is anyone has encountered same problem with Panasonic FZ-G1.

I recently upgraded my 3G mobile card to 4G version. After switching it everything worked fine for a while and I even used my steering. But after like half an hour my ethernet controller stopped working and I cant seem to get it back on. On device manager the ethernet controller Intel 82579LM is showing with yellow triangle and saying it is unable to start, code 10. I have tried quite a lot of things but nothing seems to work.

Has anyone had similar issues? Below is the what device manager is telling:

Driver Name: net1ic64.inf
Class Guid: {4d36e972-e325-11ce-bfc1-08002be10318}
Service: e1i65x64
Lower Filters:
Upper Filters:
Problem: 0xA
Problem Status: 0xC0000001

What programs a running in the back?
Maybe do a cleanboot and see if issue still there.

Does wifi keeps working??

Are you using a dock?

Try and reinstall the driver, and if ethernet is on some sort of removable module, make sure it’s seated right

i had issue with the dock ethernet as in my case it was a seperate interface device and so I hadn’t configured it correctly. Also if you are using a gsm connection for your ntrip it could be affecting your ethernet - you have to configure windows to ensure both can be active

I don’t use a dock, I have tried several driver installs, fresh windows install, old 3g controller card etc. but nothing seems to work.

I have a feeling that this problem is somehow related to Agopengps RTK. Because after I installed the 4G module, I test drove it with my Agopengps for half an hour, then noticed that I don’t have RTK signal, went and reset my RTK base and after that when I came back to my tractor Agopen had connected to RTK but didn’t have connection to autosteering anymore because ethernet controller had stopped working.

So can RTK connection in Agopengps somehow brick some ethernet setting?

Did you do the fMinimizeconnections fix?

When you shutdown 4g lte and if then ethernet connects you need that fix. So you allow multiple connections

Yes, I have been using 3G connections for couple of years already but now they are removing 3G networks in Finland so I had to upgrade connection module to 4G.

Ethernet controller doesn’t work at all at the moment, it says unable to start in the device manager.

1 Like

Was it posible to reseat internet module as andyinv suggested in November?
Else get some type of internet USB module, and try that way.

I haven’t reseated the ethernet module, it is in with screws so I don’t think it could have moved.

Correct, but reseat to rule out “corrosion”/ too little connection at any af the connectors at the module.

I checked it, connector is firmly locked into place and there isn’t any signs of any abnormality around it. I tried to wiggle it but it didn’t do anything.

I tried connection with USB to ethernet hub and that seems to work, but it seems to route connection somehow differently because it still shows same error on the ethernet controller.

Yes two different ethernet controlers. One ok the other still not ok.
This leads back to a driver problem. Which could have come together with a Windows update. You should check which driver should work with your computer. I am sure other have had same problem with the fz g1
One hit by searching Panasonic driver .

So here is an update if someone runs to same problem, it seems that problem was hardware related. It got fixed by changing the ethernert port to new one.

1 Like

Hi, where did you order a new ethernet port/module?
I have similar issues, ethernet doesnt work at all and never worked for me on my fz-g1.

Did you guys also try the fMinizeConnection fix.

This to allow mutliple connections?

From the same place I bought the tablet, a local computer store here in Finland.