Head scratcher

hello, I have 1 pcb version 2 working. I have built a second and I have 2 problems that may be related. 1- my steer button does not work to engage the autosteer, I have it set to button and save. 2- the autosteer won’t turn the motor to steer the tractor, if I hit the little buttons on the cytron it will turn the motor one way or the other so thats hooked up OK. the cytron wires to the board are hooked up the same as my working unit so I think that is ok. everything else seems OK, I can see my wheel angle sensor and bno080 is working. so I’m lost as to why it won’t steer. thank you.

In bottom right corner is icon changing color when you press button? Even if it is you still have to open a field have a AB line open and press steering wheel in bottom right corner then it will steer.

Is your motor working from AOG try testing in Auto Steer configuration.

When i click steer in the autosteer settings (the icon above REC) nothing happens, it does not steer the WAS to zero. Also i have tried opening a field and selecting an ab line. The icon you pointed out does not change color when i click the steering wheel. Thank you.

It should change color when your press physical button that is connected to PCB not when you press steer wheel icon (they work together they need both to be on to start auto steer you can deactivate physical switch in settings if you want).

Is your cytron wired good can you give us images of your PCB ?

I beleive the cytron is wired properly.

Im wondering if i dont have it shut off somewhere in settings or something like that.

In Auto Steer configuration when you expand that window you have option to select motor driver but default is cytron.

Thats set correctly too, im at a loss at the moment.

Is your PCB powered from 12v in?

Try nano pin D6 to ground and see if your icon is changing in AOG (Make sure your PCB is connected always try moving was if it not responding reconnect PCB in AgIO.

1 Like

Why the red wire from the citron is connected?

There is cytron disconnect mod that use it.

But it can be connected and not used.


The was responds, ill check the 12v in, it is definetly supplied to the board, maybe my relay is bad. Thank you.

If your motor is power from PCB and works on cytron buttons then its good. Did you try D6 to ground ?

Havent tried d6 to ground yet, i have an external 12 to 24 volt converter going through the cytron so im not sure if its powering itself with that when i see it is on and there could still be 12volts missing on the board somewhere.

I bet you a pint that this is the problem.


Ok i will try that tomorrow, if d6 to ground makes a difference what does that tell me? That i dont have 12 volt power.

Hey guys you’re right on, d6 to ground and it all works, so what does that tell me where the problem is. Is that my start button not connected properly then.

1 Like

That tells you that nano works and sketch is good.

Yes try shorting steer switch on PCB if that works then your switch is bad. If not see if your optoiso is solder good, small nouch is facing up and is resistor good value.

1 Like

That was is it exactly. Thankyou very much. It was a bad solder job on my optoiso. Got a little cocky and fast on my second one. Thank you very much.


Fantastic, pleased you got this sorted out.

This particular problem caught me out for about SIX MONTHS and I still owe @MylArti a bottle of something expensive for working out the answer.

@MylArti, I’ll drop you a PM :slight_smile:

1 Like