Hydraulic steering valve not disengaging properly

I have a hydraulic valve from Baraki, and am running version 5.7.2 with Panda. This is on a Challenger MT535B with LS.
When I try to turn the steering wheel with auto steer engaged, it will not allow me to turn the wheel, but as soon as I release all torque on the steering wheel I hear a click and then I can turn the steering wheel and the auto steer is no longer steering, however, the steering wheel icon on the bottom right of screen does not change to the disengaged color so I have to tap it twice to reengage the auto steer. Does anyone have any idea what is going on and what needs to be changed?
Thank you

It sounds like you use the old way of disengage.
Try to set number to 0.
I do not have a new pcb or use auto disengage. But it has been discussed before.
Reread the manual, and also tell us what type of system you have.

I haven’t been able to find the manual. Where would I find it?

One place is to press help in aog program.
Search for it as pdf in aog program folder.
On github where you download the AOG program or the support folders.(look for links in the text below the files to download and click on wiki)

I’ve read the wiki for the specific valve I have and I haven’t found any other manual for it.

I tried setting the value to 0 but then the auto steer will not engage at all.

I’m not sure what other info you would like. In the first email I gave the model of tractor, the version of the software, and the specific valve I am using. (the valve is controlled by a cytron, maybe that is what you wanted to know) Now I’m thinking of more you might want to know. I am using Panda with a teensy. I think it’s PCB V2, it’s not the Kaupoi.

The pressure switch is a normally open and it tests ok. Open circuit until I turn the steering wheel then closed circuit.

Also one other interesting thing is that Baraki said the steer switch needs to be enabled for the pressure switch to disengage, and I have to have the switch set to “none” for the auto steer to engage at all.

Pcb v2 means you peobably use old type input.
By value I mean value set in counts in AOG.

You could also change to new type input on your panda board/ teensy. I do not have a schematic for your board, but remote/pressuresensor should be pin 37 on the teensy. You must be using UDP so AOG doesn’t care which board get the info from sensor.

That’s what I thought that you meant, I tried the counts at 0. And I’m using USB currently, likely go to UDP maybe this winter when I have more time (hopefully)

It should work on usb as well. Your problem is same as I saw on as system running aog 4 and pcbv2, two years ago. I am sure improvement to ino was made since then.
So which autosteer ino and panda/teensy ino do you use(date downloaded and names)

Sounds like you have the plumbing incorrect on your valve, it should turn freely when autosteer is engaged and turning the steering wheel will then automatically disengage autosteer.

It also sounds like you’re not using a steer switch to turn autosteer on and off, but relying on pressing the icon on screen.
I would use a physical steer switch, things just work better.

This is the way it works when using remote on pcbv2 . Program need a full cycle to disengage.
Two years ago we had to draw steering wheel to full pressure two times withim a few seconds to make program count one number. (It had to be both on and off to count a full circle )
At that time we used a pressure switch that open when not activated.
Maybe you need another type of pressure switch, to make it work in your system.
It could also be a wrong setting in AOG, as mentioned above (automatic or manual)

We got the latest code off github today and reprogrammed both the teensy and the arduino to make sure they both were completely up to date with the latest code. It still responds exactly the same way.

Baraki installed the pressure switch so I’m sure it’s the right one.

TeensyModules\V2.5 and ArduinoModules\USB\Autosteer_USB_v5 . Is this the right ones?

Yes I would use same today :slight_smile:
Please a picture or which type of panda board you use!
I was referring to the AOG manual, thinking of page 45:
(found in AOG program folder but same can be downloaded from WIKI )

DID you resend (the mandatory part) from AOG to arduino NANO after reinstalling the INO?
ALSO we need pictures of your Button/switch settings in AOG.
(Maybe this solution could help you: Turn Sensor behaviour in steer enable mode: switch)
I did a search on this forum for following 3 words “baraki pressure switch”

Hello, you stated in a few posts up that your switch is normally open. Because of this you will have the exact trouble you are talking about.

You just need a very small modification to the Arduino code and your trouble will disappear. I’ll open that USB Nano ino and show you the line to modify this afternoon when I’m on my computer

Line 780 in the USB Nano ino add the ! in front of “lastEnc” so it looks like this. That will make it count the pluse when your normally open switch closes.

if (!lastEnc) EncoderFunc();

Thank you so much! That fixed it! Changed the code as you said.

Also thanks for your help. Changing the vehicle setting of the steering switch made the AOG software disengage the steering in the software so I no longer need to press the icon twice to reengage the auto steer.