I put together a new pcb box this week. But there's a problem that I don't understand

For reference I am using:

Today I tried to run it in the tractor but as soon as I turn it on the tractor starts steering. I can override it by pressing the buttons on the Cytron, but as soon as I stop pressing the MA button it steers back in the MB direction. I unplugged the usb from the arduino to make sure the computer wasn’t telling it to steer, but that didn’t help. The part that confuses me is it stops steering if I take the arduino out. This made me think the arduino was bad so I swapped it out with one from a different box and it did the same thing.
Any help would be much appreciated

Do you use the latest program, together with the latest ino.?
And did you program and upload settings for nano that is set in AOG, to the nano?

Yeah I did.
But would having that wrong actually be able to make it do that?

Yes set to ibt_2 would.
Or wrong wiring.

I have it set to cytron.

The way I have it wired is as follows:

Dir - Dir

That was the first thing i checked though

And you did upload from arduino ino at first and then load changes from AOG later.
Does the nano work (can it do the blink program.
Sorry but it is too late so you won’t hear more from me till tomorrow.

Yes I loaded the program in and than sent the changes from aog after.
And the nano does work

Thanks for helping btw

What are you turning on that makes it starts steering?

The entire box
Like I have the on off switch permanently crossed
I just plug it in and it starts steering

One of the problems I think there’s a slim chance that it is is that AUX 1 and AUX 2 were crossed
I uncrossed it but the tractor is at the tire shop now so I can’t know if it fixed it. I doubt that’s the problem though because it makes very little sense that that would have any effect on it

I’m not sure what AUX 1/2 are. If my memory is correct, the only aux IO are for the ADS’s extra inputs. What happened if you unplugged the jumper from the Arduino’s PWM output to the Cytron?

It stopped steering

Try connecting one pin at a time to the Cytron starting with gnd, then direction. Make sure you’re connecting the correct ones.

I don’t have the tractor rn but I’ll try that when it gets back

New development on this issue

I went to the tire shop and did some more tests
It still does the same thing but when I tell it it has an ibt_2 it stops having that problem

Time to tell us what AOG version, and exact name and date of autosteer ino you are using.

you can testdrive in sim and measure output to the dir, pwm1 and pwm2 when driving on A B line and activating turn to left or right and at same time watching ACT SET and Err in autosteer configuration or the steer chart. PWM is at bottom of autosteer configuration.

The tractor is still at the tire shop and I’m gone for the next 3 days so I’ll let you know then.


I am running in the same issue (I can get motors only running in 1 direction, only max (configured) PWM output, the sensor input is working well but the PWM output and direction seem not to take it into account) I am using the “test drive” button in the autosteer config menu to test. When I switch steering direction in the settings the motors run in the opposite direction so the cytron is working well I think…

Is your problem solved, and how did you solve it? changing the “cytron” setting to “IBT2” seems not logic as a solution to me…

Thanks a lot!

FYI: I am using
AGOpenGPS v4.3.10
Arduino: Autosteer_USB_4.3.10
test positioning wheels

To make sure I understand you correctly. When the red Rijd button is green, then you can make motor run in both directions by pressing the right and left arrows? Also you should add more min PWM

Is your WAS properly mounted and centered?

Check that the red LED, MA and MB are lighting as you switch direction and increase error. If they are, check output voltage for both directions. If LED’s are not switching, check connection fron Dir pin. Dir pin should have voltage for one direction, and none for the other.
Please post results