Import Fields with .kml

Hey everyone,
Yesterday I tryed to import my fields to AgOpenGPS. Unfortunately I noticed I only can import one field each. So imported and created about 40 fields…that was a long night. Now I noticed, that I have to open this specific field everytime I want to see it on the map. Is there a possibility to see where all my fields are? It would be very exhausting to search for the fieldname and open it everytime I switch field, because I have many smaller fields. Thank you for answeres :slight_smile:

When reenter in a field I use the “Open a Field” then sort the fields by distance with the “Sort” button. Then use the “Save As” to create a new field with the task and date.
Finding the field is real fast for me as I know the name of most of my fields. Tipping the new task is the most time consuming for me.

I am not using the “drive in” function, I prefer search and open the specific file to create my next one.

I also have a lot of fields (created 32 this year) with 3 or 4 task each so a lot of folders.

If you want to open more than one field with a boundary for each I don’t think it’s possible.
I had made some “field” that were groups of small fields for fertilizer application but no boundary for them.

I saw something about multi boundary, I can’t remember where, maybe in the survey here ? As a feature request?

Okay thanks, its just if someone other drives then me, who don’t know where my fields are they could see all of them. So they could just watch at the screen and see next to them there are also 3 more fields to work on. With the Smartphone app Farmdoc i can do this, it is a really nice feature, but i would like to switch to AgopenGPS because it sounds so great to me.

Always thought that the AOG could show the surrounding fields. So I went into the Field Picker under the open and asked it to keep the boundaries for the closest fields. Now all of these fields were imported from the kml and at the same simulator cords. But it can display the surrounding fields. Currently it does nothing but display them, but… If out of bounds in one field, can’t we check to see if we are in bounds in another field and reset based on that field. I don’t know but maybe.

In the picture below, I have a large field that contains five smaller fields at the top, and at the bottom, three fields in a field with one of the three inside of the other.


This is after opening in AOG.The purple field is the current field.


This is close and reopen with the little field selected.


This is it applying in the little filed. All of the fields that it is in the boundary are yellow. All other fields are green.



Oh thanks a lot i will try it

Yea it worked! thxScreenshot 2020-12-15 175656


Do those boundaries work?

Here is my program.


no the boundaries dont work. And i will definitly try your programm.

Mine doesn’t work either. Only the one for the current field. I have them turned off when you start the program. Go to the display settings and the lower right button Show Adjacent Fields turns them on or off. I did get it to recognize that it is in the boundary. Tried to no avail to load the ablines for all the fields as well.

Made a little progress with displaying the other field ABlines. I’ve got them loading now. More work to make them selectable.


This is somewhat possible in the unstable version,
When outside of a boundary it shows all fields.(enable autoload in settings)
And it starts the FIRST possible field you drive in.

This works fine thx.Screenshot 2020-12-16 102207 Screenshot 2020-12-16 102201

1 Like

Is that the Daniel unstable?

I looked at the code. Cool stuff. I was in the right direction. Just not far enough. Looks like it is always trying to open a field the only thing stopping it is if it is in a field now. I was always in a field trying to see what was around me. That’s where my problem was. Everything was already loaded. Do you load more? No, you load all the field boundaries if you are out of bounds, and you only load what you need if you get in that field. Genius!!!


Hey guys i tried to connect that programm with an arduino nano but it doesn’t comunicate with it. The arduino sends data (it works with the most stable version) but in this version nothing happens if i press buttons.

image It always says Steering Module not connected

did you load the ino in the arduino ?

did you set the port serial ?

with the normal version everything works fine so com is right and sure i uploaded the ino

image okay so i uploaded the code again and know the check is green, but it always says Steer Module not connected

great, better,

are you sure the ino file is the correct one with you AOG version?

okay so new update the Error Steer Module not connected is still there, but the workswitch works, so i think thats just a bug