Imu not connecting pcbv2 udp

I’ve just added an ethernet shield to my pcb v2 to upgrade to UDP from usb after being inspired watching @PotatoFarmer YouTube video (many thanks). However have run into a minor issue. When I plug in the ethernet cable the unit connects but the imu (adafruit bno085) does not seem to give a reading and remains at zero. After opening up my enclosure the only way to get it to work is to press the reset button on nano whereupon it functions perfectly. When I disconnect power I’m back to square one with no output from imu. Has anyone got any ideas how to solve this?

Thanks in advance!

Put a while loop in the setup portion of the ino to make the Nano wait until connection with BNO is established before it continues with the rest of the setup.

2 Likes

UDP is not that scary, once its all good it stays good too. Glad you enjoyed the video.

Thanks @BlackAce . My coding knowledge is minimal to at most but I’ll have a go! Is this something you had to do @PotatoFarmer ?

I run the Aliexpress Bno085, did not have to modify any code for them. Just popped the shield in like the video.

Solved! Added delay(2000) after void setup to ino at initialisation.

4 Likes

Hi guys what was the code and where do you add for the delay for the bno085? Thanks

at the beginning of setup I place it just after :

Serial.begin(38400);
delay(100);

100 is enough 2000 is a lot. (I think it could be even less. 100ms is already a lot for a machine! ;-))

Great thankyou I’ll try it tomorrow