Issues getting started

Hi everyone, I am new to agopengps and the forum. I have my arduino nano, bno,ads,mma,and cytron driver wired up but when I go into agopengps / serial ports to connect the auto steer port it connects, than says ‘Setup complete, waiting for Agopengps’. It has never worked yet . If anyone would have an idea why it does that it would be a big help.

You have to send the configuration to the Arduino in the Arduino settings section, it has options like type of WAS, cytron or ibt2

Also did you flash the Arduino nano with the .ino file?

If you are using a knock off nano did you install a ch340 USB chip set driver on the computer?

Yes I uploaded the ino file to the arduino but do I have to modify the code somewhere?

No, go into AoG configuration menu, then the Arduino config page, select the options according to your system and press the button to send the settings to the Arduino.

Sounds like you are using v4. Have you got the simulator ON or GPS connected?

Yes I did all that

I think I have v5 and yes I tried it both with gps connected and with the simulator on. It’s the same either way

If you have V 5.2 then you ha have a manual too. Click help and the. Manual. Pdf opens.
You write you have bno and mma. In V5 only bno085 (bno080) or the equivalent cmps14 works
Use the magnifying glass (top right) to search this forum for info of those two.

If you have v5 and connecting via USB/Serial it will not have “waiting for AgOpenGPS”. v5 will also not work with the MMA and BNO055.

Are you connecting v5 via Ethernet?

Show a screenshot of the AgOpenGPS connection page, and where dose it say “waiting for AgOpenGPS”

I am connecting via usb and am using Bno08x

Open the serial monitor in the Arduino program, Baud 38400 and it should look like this.

Note the funny symbols on the last line, if its not like this it will not work.

2021-07-10 (2)

Yes it looks like that

Now it says Bno08x not connected in the same place it said waiting for agopengps

That is v4.

You need to use all v4 or all v5 not half / half.

So maybe download the latest v5.2.1 and go from there?

Picture of your PCB showing the BNO08x?

Ok I was pretty busy for a few weeks… so I think I was using v4 agopengps with v5 support files but I’m not having any luck installing v5 now. I’m not sure how to open it as an app because it’s a zip file on github

Extract the zip, find the AgOpenGPS.exe file.

1 Like

Uninstall the old AOG incl. App Data and folder in Documents
Download AOG zip
Download Support zip
UNBLOCK both files before unzipping
Unzip both files
Start AOG exe

Ok thanks, got that working, now I’m having trouble with the support files not uploading to the arduino. If I go into the autosteer usb ino this is what it looks like

I was having that issue too, use the online version of arduino ide. I have no clue what libraries are missing, but it compiles in the online version.

Or alternately use xloader in the aog files, from xloader select the precompiled hex file. This is the easiest.