MF 77 series, MOTOR and CANBUS hardware guide

This guide is only about the specific hardware of MF77, even if it may few drift from it, it’s not about the AOG program, PCB, GNSS receiver…etc.

Electric steering wheel system

Steering mechanism and motor, all explained here, or maybe you’ll find another MF76-77v2 steering mount by Blaise_fr - Thingiverse

For the wheel angle sensor, we’ll use the built-in one thru the X246 connector which is front of the cab near the orbitrol hidden by a rubber protection.

  • You’ll have to remove the CAP with some shunt on it.

  • From inside the connector you’ll see 4 pins and you’ll have to add 2 pins for negative and was signal. Check which one on the tractor side.

  • Remove the central lock on the connector, ideally there is a special tool but you can use a self made hook or even just pliers. In my remember there is a latch to unlock pins or pin cap’s.

  • You’ll need 1060-16-01XX pin’s and pliers to correctly iock the additionnal cables in it. One new pins are locked inside the connector, reinstall the central lock.

  • Of course you’ll have to connect these 2 new cables to the WAS connector of the AOG PCB. |


In case your 77 is autosteer ready or even just « speedsteer » you may use the integrated electro-hydraulic orbitrol and WAS sensor thru the canbus.
On the picture below, backlight show that the speedsteer is available (bottom right symbol).

You will have to use Arduino UNO and Can-Bus shield to connect on the tractor canbus.
I may advise you to use genuine arduino UNO because it’s voltage regulator handle 20v while some clone’s only 15 and are really limit in term of heating, in that case you may use a stepdown module to supply the UNO from the nearly 14V of the tractor with running engine to less than 10v.
See photo below (sorry for quality and ugly soldering’s), note the connector I added intended to connect by bluetooth with an HC-05 module insted of USB.

Let me suggest you a case to print for it : Arduino Uno + Canbus Shield box by zenoms - Thingiverse

Remove the cover on right of the seat in the back you’ll find X230 canbus connector.
It’s a canbus termination with 120 ohm terminal resistance in it, you will need another connector from the same type to connect on the bus.
You can test it but normally your UNO can Shield have an integrated 120ohm resistance to finish the canbus.
Keep the original connector in case you have to remove autosteer from the tractor later.

/ !\ Even for test, never take any risk that the CAN wires can disconnect and get shorted, believe me, you would regret it !

You’ll of course have to upload a program on the arduino UNO, here is a list of those I used : GitHub - BL08FR/AOG-Canbus-tools-program-s: Various tool and program for Agopengps autosteer on tractor CAN

WAS calibration :
If when on AOG via the manual controls when you ask center position (0°) the wheels aren’t straight, you need to calibrate the tractor WAS thru the can.
In case you are now asking yourself if you can do it on your own, the software, AGCO EDT (electronic diagnostic tool) is quite cheap from china but the tractor interface is awfully expensive. I advise you to contact your dealer.
/ !\ Never use the WAS set 0° button in AOG, it have no effect on the tractor setting which is stored in one canbus ECU. Then you would have to delete all AOG settings in C\user\your_account\appdata\local (you’ll have to show hidden files).

For any additional information about MF77 canbus, please explore the wonderful discourse thread about it : Massey Ferguson 7700 autosteer ready

Good luck !


I got that joke probably after a windows update that pressing the guidance button on the tablet, steering stopped to work apparently without reason, if it happen, check this :

Did you get steering to engage with any button on the joystick perhaps, or are you using your own button? What method worked, if so?

Thanks for your question, I updated the previous message about it, no I don’t use the joystick button and even don’t use any hardware button. I engage steering via the tablet bottom right icon and AOG tell to the uno to send it on CAN.
It’s even thanks to your post (N°82) in the other thread that I found the reason why it stopped working.

There is surely a way to engage via the joystick button, some did, but I didn’t tried yet.

1 Like

I made a video to show how to engage using headland management button, works great :

1 Like