Mystery error

I have a strange problem with 4.3.10, with the D4 / Dir output which goes to IBT2 L + R EN and pulls relay to 6/2 valve starting to pulse like a flashing relay as soon as I leave Sim mode and turn on control, has have not had problems with earlier versions, even have a suspicion that there is a remnant of an earlier version of AOG or a stupid setting error, I use LarsV print, (v2) f9p and hydraulic control, there are some who have experienced something similar, think almost I have tried everything, had different things disconnected, WAS, ADS1115, Roll and contacts, soldered print after the switch 7805 and many other things and spent a lot of LarsV time.

Sorry if this is a bit basic but you did delete


when you updated to 4.3.10?

@Alan.Webb yes

…almost sounds like remote is set to switch rather than button. Or it thinks it is anyway for some reason.

Steer enable = button
Work Swiitch = Switch

And what about the guidance tab in tractor config? There’s a steering wheel icon you can toggle to man or auto. Try set it to manual

@Richardklasens_admin have tried both manual and auto, there is no problem as long as I am in SIM on, then I can fine press DRIVE in Auto Steer Configuration and it works as soon as I leave SIM on and connect F9P and go in and press Drive then is the problem there.
Thanks for the input

Did you tried an other nano?

@Richardklasens_admin yep and another pc

does the serial output of the arduino look ok while this is going on?

Could it be resetting? Sounds like a hardware issue to me.

What is the frequency of the switching? Roughly.

@Alan.Webb ino If you mean the numbers that can be seen in AOG then they are stable, last night I got my F9P indoors so I only had it and nano connected without AOG board, and an ociloscope on D4 and one on power after I pressed Drive, see photo. CH1 = D4

Just hook up a nano and try again

@Richardklasens_admin When I remove F9P, I need in Sim on to be able to activate Drive, and then there is a constant + 4.88 v on D4

So without a real GPS receiver all goes well?

Yes when i diable Sim on it goes wrong

@Richardklasens_admin @Alan.Webb I just tried updating F9P to firmware 1.13, as well as aothner config, nmea + ubx usb out and rtcm in, think it solved the problem, just have to try to assemble it all again, think f9p run at 1.11 or 1.12 before

Fw 1.12 shouldn’t be the issue but we never know in these Ublox chips… :slight_smile:

Let us know if it’s all fixed! We’re happy to help

Mine is using 1.12 just fine. Maybe it was sending a lot of messages previously? ISTR that being an issue when I started with AOG a couple of years ago.

Good that it might be sorted anyway!

1 Like

@Alan.Webb @Richardklasens_admin I was not lucky, the problem was there again when it was mounted in the tractor

after downgrade to Aog 4.1.1 small voltage drop on D4 D4_aogver4.1.1