No was reading again

Hello guys, I posted a thread recently where I couldn’t connect my pot without ADS1115, and Alan Webb helped with a code and it worked. But now I assembled my pcb v2 and I got my ads1115, sent the correct code to arduino and I get no response. Bno08x started working from
the first try but no matter what I try I cannot seem to get a response from the was, just some random numbers fluctuating a bit.
Searched the forum and found that it might be a faulty ads1115, so I put in the i2c check script in the arduino, it finds a device. Tracing with a multimeter I get voltage all the way to A0 pin on the ADS1115 itself.
What am I missing here?

For testing, you can connect a 10k Poti instead of the WAS to the analog input, (middle pin signal, left pin gnd, right pin 5V)

What WAS sensor for rqh100030 on PCBv2 you connect it like this:


If you change wires you get random high output. Try measuring voltage at output pin when rod is 90deg from connector it should be 2.5v
If you power PCB from USB you will get small fluctuations (0.2deg±) if you power from 12v WAS should be stable.
IF WAS reading freezes reconnect in AGio.

That’s what I was trying at home. I have had the system work on a breadboard in a tractor, but now all the parts have arrived I assembled the pcb. When I use Alan Webb’s modified code I get the angle read correctly. Is it possible that I’m having problems because the pots are 50 and 100k? Or that doesn’t matter?

I actually tried with pots 50 and 100k. On my tractor I have a headlight level sensor from a bmw e60. Does the actual WAS need to have exact specifications? Also what do you mean power via 12v, won’t I fry the ADS1115 and the arduino then?

Power PCB from 12v in then you will use linear DC DC Converter on PCBv2 they will provide stable voltage for was and nano.

Exact no but your WAS should cover your wheels turn angle and you need to know how to hook it up there are a lot of WAS sensors look on forum if someone uses same.

Oh that, I am powering via 12v, for now it will be via 220v inverter and adapter that makes 12v. I have already installed that was on the tractor and I’m using almost it’s full range, it’s setup correctly but I can’t get was reading on the bench with my pots. Could the ADS1115 be defective even though I find it with a i2c code?
P.s. English isn’t my mother tongue so sorry if I can’t get my point across sometimes.

Why not using the original code now?

With the original code I cannot get a was reading. Everything is wired properly and still nothing. Read the original post you’ll see I tried, also measured voltage etc going to A0 pin on the ADS1115 but nothing comes out in agopengps.

Did you try another analog input ?

I am not sure what you mean, it’s all soldered on the pcb, do you mean try a different ads1115?

Where is output pin from WAS connected on pcb ?

As per the schematic you uploaded, I can read the changing voltage all the way to the ADS1115. I tried plugging it to sense low too, and reversing + and - on the pot as well, but to no avail.

I meant, trying another analog input for example A3. You can use a breadboard.

Updated my AOG from 5.4.2 to 5.4.5 and it somehow managed to work, absolutely nothing else was changed. Thanks for the support guys.

2 Likes

It’s always learning and in the automation world - reset - power off - cold boot - reload application again and finally it’ work. See also on windows computers …

1 Like