Not founding GPS AIO 4.1 micro

I received F9P micros today but…

There is no light on pcb’s 3 leds. F9P led goes red very easily when touching antennas wire( I think that there is something wrong there). I Have 1.32 files on my micro. I had WAS(canbus) and IMU working earlier and these are still working. I Have 5.7.2 aog

Edit: wrong picture

If I understand you right, and you’re using CANBUS, you need to load a firmware that’s modified for the AIO (not the standard one).

You can get that here: GitHub - lansalot/AOG_CAN_Teensy4.1 at AIOChanges

I have Autosteer_AOGv5_Teensy4.1UDP_SteerReadyCAN_AIOModified.ino in teensy. Is this right?

It is but I’ve just checked and line 12 is commented out. Removed the two leading // characters from it. And recompile and send. I’ll fix it up later

1 Like

I think I had it right. I uploaded it again without //. Now light next to F9P does not go green at all. It is only red and the light is not allways that bright. Problem might be in antenna cable, F9P micro on pcd soldering or somewhere else🙄. Can it be powering pcb? As you can see, the 3 leds are very dim. I thinh the midle one is off dut lowest led is red but it is very hart to see the light.

Measure the voltages and check for cold solder joints and damaged headers.

Voltage drops to 2V when F9P’s light goes dim. Female header on power suply is not tight. Maybe I tested voltages with too big pin so it got too wide for micros 2mm pin😡emphasized text

If you swap the pins in the firmware, you are able to use the other socket?

I’am not much of a programmer, but first I will look into it before I do more damage to my pcb

The firmware will automatically look for a module plugged into the left/right side when in single. You can use either socket for single without changing the firmware.

1 Like

On the AIO with regular firmware, yes, but this is the adapted code Tony wrote for his board. For an AIO, the GPS will need to be in the right-hand port, there’s no swapping/checking to left.

Tony’s CAN code doesn’t support dual. The pins are remapped this way for AIO.

#ifdef isAllInOneBoard
#define Power_on_LED 5            //Red
#define Ethernet_Active_LED 6     //Green
#define GPSRED_LED 9              //Red (Flashing = No RTK)
#define GPSGREEN_LED 10           //Green (ON = RTK)
#define AUTOSTEER_ACTIVE_LED 12   //Green
#define ledPin 5        //Option for LED, CAN Valve Ready To Steer.
#define engageLED 24    //Option for LED, to see if Engage message is recived.
1 Like

So I will do some soldering then. Thanks for yours knowledge

Checked the diagram, the F9P LED is lit by the F9P itself, Teensy doesn’t control it.


As it goes through a 1k resistor, and the LED has a VF of 2.7, so won’t be that bright I think :confused:

It’s still bright enough

I soldered ampseal to another pcb and now F9P has 3.3V all the time. Still no GPS on AgIO. I’m I doing configuration tje right way?
After i update firmware to UBX_F9_100_HPG132… .bin u-center looks like this

Then I do receiver configuration with 1.32 singleantennarover.txt and click Transfer file → GNSS

After that I click this

Light next to F9P is red and AgIO

Do I have to do something in AgIO that it will recognise GPS?

Wich pin is right one to power pcb? I have + in 22 and GRD in 23? Should +12v be in pin 20?

Now I have tested 2 pcb and 2 F9P micros and the result is still the same. I think it must be that I’m doing something wrong in configurating F9P. Are the files same for standard and micro f9p?

12V+ Power in on Pin 22 and Ground Pin 23.

Ampseal Pinout Table.pdf (70.8 KB)

Are you saving the config by going to ‘Messages View’ then ‘UBX’ then ‘CFG’ then ‘CFG’ then clicking ‘Send’ and have baudrate at 460800.

Yes I have tried that way and the other way receiver, action, save config.