Problem RTK Fix - NTRIP AOG vs NTRIP Ublox vs XbeeESP32

Good to all, I wanted to consult you, since I installed my AOG system with 1 ardusimple board (basic kit) connected via USB to my PC, an OEM WAS (I’ll leave a photo) and a national production motor, with about 7.1kg / cm at 24v with 625rpm, running at 12v. I am using the PCB v2.0 connected by USB, all this to a notebook which I give wifi to with my cell phone since I have a good signal.
I generate the corrections through the AOG NTRIP, I am using the free networks of my country as a base, the base is about 100KM.
The problem is that although I get RTK fix on the AOG screen (photo), the reality is that the system does not behave as if it had, it moves from side to side and the engine is always lost trying to correct, it cannot to follow a straight line the light bar indicates that it is jumping from 30cm to 80cm then it returns to 0, it is impossible that the motor can correct, For this I think that my GPS signal is failing.
Disconnect AOG and put UBLOX with the same NTRIP and I get a precision of 3cm-> 0.03 (m). (Photo)
Which gives me to understand that with that precision you should be able to follow a straight line.
What may be happening?

A question and I can open debate, is that they recommend to do, use the NTRIP direct to the F9P by means of an esp32 (I already managed to install and configure XbeeESP32 I have not tried it yet) this would improve somewhat ?, Generate the corrections with another means outside from the AOG NTRIP (read it not working well), or buy another F9P to use as a base?

I await your responses and thanks.

You need to update the speed of the F9P, its running at 1hz, this is wayyyy to slow, corrections will come in super slow, causing AOG to occilate wildly as the difference between each update will be huge.

Set to 8hz and all will be well!

Please upload the config from here into your ublox device. Ublox F9P - Config for rover

I am already using that configuration Rover F9p of aortner I will update again I think I have not forgotten any step, are you saying that AOG indicates there (photo n° 2) the update speed?, That number is sometimes put in RTK Fix: 2 hz.

Needs to be 8hz, set the ms in ucenter, make sure you save config…

I found my error, when importing the config in the f9p forget to mark a check, the funny thing is that it appears gray in generation 9, put generation 8, apply the check and went back to 9, and voila, it must be an ublox bug.
Save the config and
then I opened AOG and RTK Fix: 8Hz sometimes 7hz.
I’m going to test my tractor again.
Thank you so much.


Think that option might be new, I have never used it, but I just always go into “save configuration” in ucenter receiver settings every time to make sure its saved, otherwise as soon as you restart F9P it is gone.

With 8hz things will be much much better, even 5hz is enough to make steering very slow / erratic and normally occilate, nevermind 1hz! Good luck :slight_smile:

It came to the head we mentioned. I configured it in the evenings, it worked very well. I turned off the system and everything changed when I tried it again in the morning. How do I save it, can you show it with a picture?