Problem with new pcb

hello, first time posting on here, hopefully i’m not posting in the wrong place… I just got my pcb soldered together, and i’ve run into some issues. I initially had the nano plugged in, and later took it out, at this point had not connected it to the computer or anything. I uploaded the sketch and plugged the nano into the board and there was smoke… Now i dont consider myself very knowledgeable about these things but i took that as a very bad sign. Searched the internet a bit and concluded that it was the diode right under the usb connector that was smoking. So I carefully inspected the bottom of the board for anyplace that i might have shorted something together and found none…At this point i decided to try another nano, it too smoked… In the meantime i used a rag and cleaned all the excess flux from soldering off the board and tried again. No smoke this time, so that seemed good. I uploaded an example blink sketch to the arduino to see if it still worked and it seemed to, so i proceeded to upload the agopen sketch onto it. This afternoon i tried connecting it to the wheel angle sensor to see if it would work, but it just says waiting for agopengps, even when i have it connected to the correct com port. Putting agopengps into simulator mode causes the RX light to blink on the board, but not the TX. When i take the nano off of the PCB, both the RX and the TX start blinking and there is a static string of numbers in serial ports page. When i plug it into the PCB again, it just shows waiting for agopengps. I am kind of at my wits end right now, not sure where to start looking. Any ideas are welcome. Thanks

Velcome here. You must check voltage on 5v places on PCB (without nano ) I suppose you have 12 v in on board.
Look at the pictures in the hardware PCB thread here on forum, to see if you have your components put in same way.
PS. Nano will try to feed 5 v on the board (one of the 5v circuits) so check carefully again for shorts.

Thank you for the suggestion, I will get my multimeter out and check everything out. Yes I have it connected to 12 volts, I have checked a couple times to make sure everything is correct but will check again.

As you have already seen smoke :frowning: I also suggest after checking circuit, and you have 5v at the correct places, unplug both MMA and ADS 1115 , and see if nano blinks correct without them, then try reinsert one at the time.
It would not be the first broken ADS, if that is the case here.

I think that there may be a problem with the header for the ads. I checked the board and as far as i can tell there seems to be 5 volts everywhere that it should be and components are installed correctly. With the arduino off of the board but plugged into computer, i took a jumper wire and started going down the board trying each pin on the nano while watching the tx, rx lights on the nano. When I got to the A5 and A4 pins, the tx lights stopped blinking when I plugged in the jumper wire to the corresponding socket on the header on the pcb. This was done without the ads plugged into the pcb. I know that I had some trouble when soldering the header for the ads onto the pcb so… :man_shrugging: I don’t know, maybe i’m barking up the wrong tree…

ok I desoldered the header for the ads tried putting the nano on the board. At first it didn’t seem to work but reconnected in agopengps and both tx and rx lights blinked. So I thought that i maybe found the problem. Alas it stopped working shortly thereafter so i am not sure what to think now… maybe theres something obvious in the pictures, besides my less than stellar soldering skills…

photo_2021-03-28_13-06-49 photo_2021-03-28_13-06-54

By the look there seems no short on A4 and A5 so there should be no reaction connecting nano to them. But try measuring ohms between gnd and those 2, must be high ohm /not connected.
Check pin 5 on ads, you have left some solder, but that should not interfere right now.
Recheck pin 1 and 2 (5v and gnd) on ads1115 maybe you soldered a shortcut there, such a short would burn the connection between USB 5v and 5v on nano (look at back side of nano)

First off thanks for your help…theses are the results of my testing, i hope i understood your directions correctly…

a4 and a5 to ground=no connection.

pin 5 on ads to ground=connected

pin 1 on ads to ground on nano, ohms dip down to about 130 and then stabilize at around 156 on my multimeter

pin 1 on ads to 5 volt on nano=connected

pin 2 on ads to ground on nano=connected

pin 2 on ads to 5 volt on nano=not connected

pin 1 and 2 on ads are not shorted, i’m not sure exactly what to look for on the back of the nano though…


image image

one other thing of interest, the led on the pcb randomly flashes on and off, flickers. At the moment i just have a farmers style setup, providing 12 volts to the board from an ac to dc adapter, could this be part of the problem? although I also had it in the tractor plugged into the battery and it didn’t work then either so…

If it says waiting for agopengps, do you have nmea hooked up? You won’t get anything from your autosteer board until you also have nmea connected to AOG.

Ok, no I didn’t have nmea hooked up… but if I have the simulator turned on, wouldn’t that sort of take the place of nmea in this situation, bench testing?

Yes I think you’re right. I only tested on the tractor, so I didn’t think about that…

And you didn’t turn on ntrip.
If the on diode is blinking, then you have unstable 5v or 12 v.
Is it blinking even without the nano on PCB?

Let’s say power is OK. Did you shut down arduino ino before starting AOG?
Please post screen shot of that waiting for agopengps thing you have.

I will check the ntrip thing, light blinks even without arduino. I’m at work right now, will check the rest out once I get back home.


maybe I can hook in at this point.
I have a nice running system and everything works.
I bought some new Nano as a spare. COM port selection and uploading the INO is absolutely no problem. But when I plug this new Nano onto the PCB it takes quite a long time till COM port in AgO is connected. Once it is connected I get an absolutely wrong wheel angle value and steer motor does not turn. Also in manuel drive mode I set an wheel angle but no PWM is outputted.
This fault I have an several new Nano.
If I plug in my old one with the exact same INO everything is runnig.

I have no idea what is causing this problem but i can imagine it is on your side the same.


The com problem, could relate to the issue here where 5v from PCB before usb cable prevents windows to recognize nano. Arduino COM port issue

Just to make sure : but did you resend settings from AOG to new nano?

Thanks @Larsvest .
Just checked it. Do not make any difference if first powering Nano by PCB or USB.
COM port can be connect without problem. Also loaded the module configuration in AgO onto the Nano.
The green check sum is also fine.
But still wrong wheel angle and no PWM output in the drive mode.

If I compare both of my Nano optically my none working ones look like that from clark above. It has this two yellow components on the back side.

Well, too bad to hear, so maybe mention nano type not to buy.
My nano look like your working one, I suppose something else is wrong, as colour of capacitors would not make a difference :slight_smile: