PWM don't work

I connected Keya to AiO v4.5, set up line A, and activated autopilot. Why does the PWM show 0 and the motor not rotate

What firmware are you running? Check this thread for info on how to get it running. Keya CANBUS motor - great success, many happy etc Also, there is a AOG Keya Telegram chat that is more active than a Discourse thread. It is here Telegram: Join Group Chat

1 Like

I think your Autosteer button/switch is off or you need to tap the red icon to “arm” Autosteer.

1 Like

I installed the selected firmware.

I connect pin 8 with pin 21 and light on screen is on.

but still nothing happens

I think i had same problem with new keya, config o matic configs didn’t work had to flash teensy manually. If i remember right this worked AgOpenGPS_Boards-Old/TeensyModules/V4.1/Firmware at 575R-Keya · m-elias/AgOpenGPS_Boards-Old · GitHub

1 Like

I installed this firmware on Teensy and it still doesn’t work, steering wheel model: EBB 076 DBZ7. PWM = 0 and the tilt icon is all the time red.

Steering setting activivation to Button and press that Button on board it should go green

1 Like

After several hours of agony, I finally managed to make it work. I have no idea what the cause was; suddenly it started working. I installed AOGConfigOMatic v0.1.0.15 - Keya Motorwheel (for PCB4.1 and Keya CANBUS). I’ve had enough, I’m going to sleep.

1 Like

I ran into what I think was a bug yesterday with similar behavior to what you’re describing. Steering would not enable when the the “steering enable” setting was set to “none.” I tried for hours, eventually changing out every single part of my system except for the GPS antenna and the Phidget motor. Here’s what worked:

I was driving inside the borders of an open field file, my autosteer was turned on (green steering wheel in the bottom right), I opened the steer settings page where you select Button, Switch or None, selected “None”, saved my settings, kept the settings window open, turned off the steering by pressing on the steering wheel icon in the bottom right corner, then turned it back on. This enabled steering.

Frustratingly this only worked once. I was not been able to reproduce the solution a second time. Instead I installed a physical button, and that works every time.

I hope to write up a bug report if I can figure out what combination of things I did to cause the problem, and if I can reproduce the solution.

1 Like

I installed everything on the tractor, this time everything lights up green along with the tilt icon, but PWM is at 0 and the steering wheel does not turn.

Try to wiggle around the jumpers on the board. I had a similar issue albeit with a phidget’s motor and then when I did that everything suddenly started working.

Edit I also don’t get anything unless I use the physical steer switch. Pressing the one on the screen doesn’t work for some reason for me regardless of steer switch settings and manual/remote settings

1 Like

Resistance steering CAN = 129 ohms
Board resistance CAN = 33.5k ohms
Voltage CAN L- CAN H = 0.85V

33.5k ohms seems too large, doesn’t it? But the CAN voltage is there, so I guess it’s working?

The light on the steering wheel is on.