'Remote' switch not being recognised in ag? What am i missing?

Installed a ring of magnets around the steering wheel and the hall sensor from the build file, wired into remote, as to cut hydraforce valve when steering wheel is turned.

Switch is working as the the LED on the sensor lights up each time it passes the magnets.

When i cross negative and common with a wire connection there is no change to number in the data stream, there is a change though if i do this on the imp switch and steer switch.

I have tried changing the optocoupler, but was still the same.

What am i doing wrong, will be something simple i’m sure!

Do you have 12v powering the board when you are testing or just the nano plugged in via USB?

Probably bad pcb. My pcb has a faulty motor switch spot, so I had used the remote switch spot to turn on/off the motor.
Try a different one

Yes I had 12v coming to the switch, as I thought that was wrong at first, untill I did some reading to find that was normal.

That’s my plan today to plug another board in! I’ll let you know how I get on!

If you don’t mind about optocoupler you could also use the free pins, d4 d5, don’t remember exactly what are they.

Make sure you have the turn sensor turned on in the module configuration

1 Like

So I have tried another board… Same problem.
I have turn sensor selected in module configuration, and sent to module.
When I make a short between common and ground there is no change made in the data stream.

4vs when not on a magnet, 12v when on a magnet with sensor led on

Still trying to think what I am doing wrong!

How many counts did you set, before it should turn off steering?
What ino name/number do you useU
Which type pcb do you use?
Is “autostreer” on? (at least one green spot, in AOG 4.3.10)

It appears that remote does not work on any of my pcb v2 boards. Dont know if this is the same with all or a fault I have made… maybe someone could confirm.XXX EDIT It was a fault with my board!!!

With help from people on telegram group, I changed the pins around in the INO, Work switch became remote.
It now works perfectly! Although I am going to have to look into how to make my work switch function again.

Thanks everyone for you help on this, I was getting very stuck!!!

What line of v2 board are we talking about, as I have no problem with my board made from v2 schematic.

Seeing as 2 of your 3 inputs are working I doubt this is your problem but see my issue here.

Ive just had a good long look at a photo of my board and another from the forum… i have at a minimum soldered the wrong resistor into R4 I have a 1k there when it should be 330ohms. I must have copied my own wrong board when making a new one, so they all faulted the same!
Edit… also my arduino nano was not working on pin8, new nano, correct resistors… everything is fine!
All these mistakes make succeeding taste much sweeter!