RTK Base Fix

Can anyone help me to obtain a base station fix per chance as I have been banging my head off this for a week and every time I think I have it cracked it works out I don’t!

Am I making some category mistake when it comes to relative vs absolute position?

Problem: regardless of what I do, my base station fix drifts around like it’s just gubbed a bottle of whisky!

I have loaded the base config provided by ardusimple, enabled the necessary constellations and run the device in “survey-in” mode until ucentre has reported 3D/GNSS/FIXED. Recorded the XYZ coordinates and plugged these into RTKBase.

And whenever I look at it, the current position can be anything up to 10M away from the recorded fixed position and altitude is fluctuating by up to 10M.

Am I misunderstanding something here? Should the base present a constant fix in the same location? I appreciate that there is no such thing as an absolute position in space and so wonder if I’m simply expecting too much, but does everyone’s base station wander around like some aimless drunk?

Your base takes position as normal GPS receiver, base station calculates the correction needed to eliminate the error in the position calculated at that moment from GPS signals. Difference in position is your correction data.

Seams high but do you have problems with RTK or it just bothering you? If it works then it’s normal.


To be completely honest, my rover alone was holding a pretty straight line without a base.

Ok, here’s the thing…

One of my neighbours is a pretty well known archaeologist who is in the process of conducting an absolutely massive survey (it was the world’s largest, now Number 2, but heading back to Number 1). He is paying a small fortune for RTK corrections for his tools and keeps grumbling that the altitude is off by up to half a metre which throws out his results.

I want to offer him free use of my base and have read that the RTK2b board can achieve 2.5cm altitude precision which excited him. AS themselves even detail a trial in which they drove a car tens of miles and retained 2.5cm precision.

But honestly, I can check and it reads 80m, check back a day later and it’s reading in the high 60s. Just can’t bend my head around why.

This is the problem:

If you look at the above image, there’s an altitude difference of 5m.

In the image below you can see the black fixed position and the blue tag indicating the current position. This is the worst I’ve seen it and it did correct fairly quickly, but it is literally over the road from the antenna!

When a receiver is acting as an RTK base station, in U-Center the Fix Mode should be “TIME”, not 3D/GNSS/FIXED, which is the receiver working in rover configuration.

Did you save sure the settings to the receiver after surveying in so that is doesn’t revert to previous settings when turned off and on again?


Ahhhh, now that makes sense.

I have just configured and installed a base for a local farmer, another member here, and he has got TIME. I must have dumped the wrong config onto my device or picked up the wrong board after I configured a base and rover.

Is this (TIME vs FIX, etc) documented in the ucentre documentation? I did do some googling and found nothing.

Yes, I did save it, I made sure to send each change after I had made it.

Saying all of this, even for a rover those results are pretty terrible, as bad as simple GPS. I will have a play though.

Many thanks, that’s been driving me nuts.

You nailed it.

I hadn’t updated to the firmware so the config upload had failed.

Perfect, thanks.

Now this got my attention. What changes are needed for base station use for ardusimple f9p apart from factory settings?
Or does RTKBase make necessary settings during installation?

After firmware update I did’n make changes for f9p settings.
I have been monitoring my base station with ucenter for a week now. Fix Mode is 3D. On deviation Map maximum is about 4 m Lat and 2 m Lon from average, mostly within Lat 2 m and Lon 1 m.

Fix mode needs to be TIME for base if its 1.13 firmware you need to load ardusimple base config and save it.

1 Like

I did base config 1.13, SEND ect. and I had TIME, but when I start “Survey in” I have 3D/FIXED, is this ok? For the survey I have connected to ntrip base for better position.

For surveying time yes after survey is over it should switch to TIME but I would recommend writing down coordinates to TMODE3 then your base is always using same cords no surveying every time you power it on. And your AB lines will stay in place for repeatability.

Don’t forget to send and save.


I have noticed that ucentre now prompts to save all changes whenever the user changes screen which is a useful function.

The last thing that I’m unclear on is TMODE.

There are three TMODE options, TMODE, TMODE2 and TMODE3. Do all of these need setting to survey-in for the survey period?

Also, are you saying that (once we have a stable TIME) that TMODE3 is set to fixed with the TIME coordinates (TMODE and TMODE2 are left at survey-in)?

1 Like

I left tmode2 and tmode on default settings never opened them only tmode3 is set to fixed cords.

1 Like

Great, many thanks.

And once they have a TIME position, set this as fixed in TMODE3?

After long survey you can write cords from survey in to TMODE3 but they can be off by 1m from absolute position. Look up PPP if you want to have absolute position of base for normal use of AOG it is not needed but if you want to do stuff with your cords it will be problem if your base is not referenced to anything at any time.


That’s the clearest explanation I have seen on the matter.

Thanks again.


If you have “an NTRIP base for better position”, you could configure your base as a rover first, feed the NTRIP correction to obtain RTK fix. Then record the reported rover position for a while and calculate an average. There you have a very accurate base position and it does not take long (assuming your NTRIP source is good).

I would use survey only if no other NTRIP source was available.

1 Like

The coordinates you see on the status page are only an estimate in realtime, so you can forget these. What is really important is the coordinate you enter in the settings page and the method you have used to compute these coordinates.


With RTKBase, changing the Fix mode is unuseful. Only SFRBX and RAWX messages are used to convert them to Rtcm/Rinex/and so on…

1 Like

If your F9P is usb connected during RTKBase installation (or during the first boot if you use a flashable image), yes it will be configured automatically.
In short, it is default settings and:

  • RAWX enabled
  • SFRBX enabled
  • SBAS disabled
  • NMEA disabled

Details here: rtkbase/U-Blox_ZED-F9P_rtkbase.cfg at master · Stefal/rtkbase · GitHub

PVT, SAT, SIG are only useful to “see” the signal if you connect U-Center on RTKBase with a network connection (port 5015).