RTK base station with M8T help

I’m getting really tired of beating my head against this and managed to get my IP banned from rtk2go now for too many failed connections.

I’ve tried using just the standard rtklib str2str as per a few instructions I’ve read, notable rtklibexplorer articles but not getting any results. It’ll post a line for my mountpoint but it’s not containing the RTCM info as all (most) of the other streams. I’ve reset and configured my M8T as per

and tried to get it on using

sudo str2str -in serial://ttyACM0:115200#rtcm3 -out ntrips://:@rtk2go.com:2101/BarK3

I’ve also installed GitHub - taroz/TouchRTKStation: Single-Frequency RTK-GNSS Rover/Base Station based on RTKLIB on my base rPi and set up the Base config with a NTRIP Caster output active. I can connect with AOG and it says “listening” but I’m not confident that it’s actually doing anything and there’s no way to really tell from the AOG interface as far as I can see. If I try to connect to this via the NTRIP client option in Ublox Ucenter software, I can’t pull up the mount list nor can I bring up an http page on the port via a browser as I’d kinda expect.

I try SNIP, set up a caster using the M8T but the most I can get is “Pending” for the RTCM3 stream.

Everything I read seems to indicate this M8T should be capable of being a RTCM base station, but apparently I’m not capable of setting it up. Any ideas where I’m going wrong here?

Are you using strsvr to convert your output from your M8T base to RTCM3? The M8T, as far as I remember, cannot not generate RTCM3 messages (M8P’s can). Is your M8T base in time mode? Have you done a survey in (using timemode 2 for the M8T) so it now shows time in ucentre.

I did start using M8Ps but have found configuration much easier with F9Ps. The M8T for rtk is even more complicated than the M8P’s as it involves using RTKlib as the chips don’t provide an internal rtk solution.

convert your output from your M8T base to RTCM3

Do you mean something along the lines of this: STRSVR commands at startup · Issue #213 · tomojitakasu/RTKLIB · GitHub

Take the RAW output and use strsvr to output rtcm, and then pipe that to str2str or my own caster?

News to me that the M8T doesn’t output RTCM, but that explains so much that’s been confusing me about the lack of results I"m getting.

Yes, although I haven’t experimented with this I believe you can use strsvr to convert your raw M8T correction data to rtcm3 and also send it to rtk2go.

You can see what messages your m8t is configured to output in the packet console in ucenter

Why not use the UBX format to output Base data via RTK2go. Rtknavi can calculate the exact location from this.
Use the file “m8t_1hz_uart.cmd” for Base.
And “m8t_5hz_uart.cmd” for Rover. It takes its own time to form RTK-FIX, but this also stays at the edge of the forest
I have got good experience in this layout.
![Setting1|496x500, 50%, Setting1 Fix_and_Hold Outputs

1 Like

Thank you for the configuration.
2 little details :
Have you better results with kinematic instead of pedestrian ?
Have you better results when disabling Glonass ?
Otherways, I run the same configuration (M8T + Rpi Zero W), RAWX and SFRBX
send to rtk2go in Ubx format, and it’s not so bad …
Best regards

sudo str2str -in serial://ttyACM0:115200#ubx -out ntrips://:PASSWORD@rtk2go.com:2101/BarK3#rtcm3

I haven’t tried it on the M8T, so it’s just a guess
As other people say, I recommend RAW OUTPUT
You also need to register your email address and get a password for RTK2GO

Hi francois.

I’m using your config and str2str command line from here: RpiNtripBase - #5 by Alan.Webb but wasn’t getting anything useful on it and now it, and since my unsuscessful attempts got my IP banned, I can’t look at your caster table entry to see what you’re getting for a mountpoint output.

Position mode Kinematic. (pedestrian is not in this menu)
Pedestrian is selected in the cmd file settings. (use some filters)
At some point, Glonass interfered with the location and took longer to get the Fixed signal. The signal was unstable, most of the time was Float than Fixed.
Today, the solution seems to be Fixed all the time.
Since I am satisfied with the current activities, I have not tried
other settings.
Best Regars

@MylArti :
Thnk you very much for your config, I’ve removed glonass from m8t outputs and in rtkrcv and added by the same way beidou. I’ll see if fix is better …
What is exactly your config ?
Have you verified with ucenter that you have RAWX and SFRBX frames and that both serial (at 115200) and usb outputs are activated ?
First try to send ubx on rtk2go, it’s straightfroward, i’ve indicated the command (after you can test rtcm output from str2str, I’ve never test that)

@Francois: As per the message of yours in the link I put up, I’ve been adding RAWX and SFBRX to UART1 and USB in ucenter manually. I’ve also used the example from Pi Zero Based GPS data logger – rtklibexplorer that uses a pi zero and str2str. In that, they reference a cfg file up for the M8T to use on the str2str command that I’ve tried (# Set sample rate low while configuring receiver!UBX CFG-RATE 1000 1 1 - Pastebin.com)

So I currently have a SNIP server set up since my IP got blocked from the public one. In it I’ve created a PushedIn Stream for K3 and start it as Parsed. I send the stream with

sudo str2str -in serial://ttyACM0:115200#ubx -out ntrips://:pass@

After teh SNIP server has had a while to parse, I can rightclick the stream and go into RTCM Viewer that looks like it’s getting 1004 and 1019 messages, but the output of the caster table still looks like


for that mountpoint. If I go to AOG, it connects to the NTRIP server and all seems fine, just as before. But I don’t trust that it’s getting anything useful given the above mountpoint output that is void of anything like the other, known good casters in the rtk2go page show. I don’t see a way to actually see what is happening in AOG. Just to point out, I’m simply using another M8T connected via USB to the AOG tablet, similiarly configured, and then set the NTRIP server address and details.


I’ve done a quick turn yesterday and indeed, fix is faster and more stable
(I’ve set Galileo, SBAS, GPS, Beidou in M8T and in rtkrcv and gloar = fix and hold)
Excuse me again, but I’ve an additional question :
At which rate do you work in base and mobile (tractor) ?
(For my config, I’ve actually set 1 Hz for base and 8 Hz for mobile)
Do you think it could be worth to go faster, particulary for mobile ?
Best regards,

I think 8Hz might be better for Rover. I have used 5 Hz longer period of time that seems to work. Maybe I’ll try 8Hz for Rover today.

It seems like using the #rtcm3 on the output is the way to go, str2str will do the translation from ubx that way. Then you can specify -msg (1004, 1005, …etc)

Thanks for the tip.

How to use m8t with AOG Version 5 ?The absence of a VTG message seems to be a problem becose i’m using RTKLIB for RTK FIX. No speed in AOG. The tractor is moving but is pointing to North all the time.
I’m still using AOG version 4.3.10 until this problem is solved .
So how solve this problem?