RTK on only one F9P (over xbee radio)

Only one of the F9P lights on my Micro 4.1 is turning green, but I am still getting the big LED light to turn green and say I have RTK. When stationary, AOG indicates my location within a couple of centimeters. However, as soon as I start moving, the precision drops, and it further decreases the faster I go, with steering accuracy declining.

I flashed both F9Ps with AOGConfigOMatic and configured them for the proper slots. I have swapped them around and reconfigured them with AOGConfigOMatic, but I get the same response (always the same socket, the right), so it isn’t the F9Ps. I plugged the GNSS receivers into the opposite sockets and got the same response, so it’s not one of those either. Additionally, I have tried three of the Micro 4.1 boards I got from JLCPCB, and I got the same response, so unless there was a problem with all of them, it’s not the board.

I have a simpleRTK3B Pro base station that I configured according to How to configure simpleRTK3B as static base station - ArduSimple. I have a DIGI XBP9B-DMST-002 (https://www.mouser.com/ProductDetail/Digi/XBP9B-DMST-002?qs=%2Fsr0sUXBX%2Foiu%252B5b6BKNJQ%3D%3D) installed on both my base station and tractor. My understanding (from Help Configuring Radio RTK) is that if I have identical radio modules, no configuration should be necessary. Also, since I am getting RTK on one F9P, I assume the tractor and the base must be communicating.

Is this a problem with my base station configuration or my AOG configuration?

In the pictures you’re only showing gps single which would be a problem.
Is you’re ntrip configured?

I do not have dual, but isn’t it so that one f9p is moving base and give “rtk” to the other f9p. To test that, just remove your xbee radio on the aio board, and see if you still get the one green.

1 Like

Another person with a similar issue on telegram…. Sure he has Rtk but his troubleshooting video is showing single. It’s not a bug with the latest version? Not to show Rtk fix?

Not using ntrip I am using a radio base station.

Yep removed the the xbee and it behaved the same, showing I had RTK on the left F9P led and the main led. So what’s next? My understanding is that all the communication between the radio and the F9Ps are done on the Teensy. Is there some way to even confirm that I am even receiving a radio signal?

I don’t think teensy is involved. I have xbee Bluetooth on top of a standard f9p, to receive correction signal from phone. As I remember the schematics for AIO boards, signal goes directly to f9p from xbee slot.

The Micro has three little silver squares at the bottom of the board (solder pads I think you call them) with the label “RTK Dest” brackets from the left to middle labeled “F9P” and brackets from the the middle to the right labeled “Teensy (default)” and a little dot connecting them and showing continuity on the multimeter.

The teensy receives the corrections from the xbee and forwards them to the radios. For some reason in the official firmware the radio baud rate is incorrect. You must change it from 9600 to 115200 and re flash the teensy


Okay, so I guess I need to go through the instructions here Configuring The Teensy · AgHardware/Boards Wiki · GitHub for doing it the hard way and change the code.

Try the firmware in the GitHub link below.

1 Like

Flashed that firmware with Teensy Loader, no change. Also tried manually changing with Teensyduino (see screenshot I think I did it right) and no change.

Since you can access the XBees via XCTU over USB on the simpleRTK3B I got the idea to climb up to my base station at the top of my barn with a tablet and the XBee out of my tractor to see if one of the Xbees was the problem. Both appear to work fine, however as you can see in the photo below the baud rate is 9600. So that was never the problem.

Poped them back in the proper places and tried again (with the official firmware back on the Teensy) and again, same situation. So it looks like I am back to square one.
Everything else works great on my system and I am excited to get it going, but this is proving quite frustrating. Did I maybe buy the wrong XBees? I bought all the parts a while back and I can’t remember why I chose these particular modules (other than they had the right frequency and they fit the slot).

Thank you Guy1000, then I learned how teensy handles xbee signals. And that the correct baud rate is 115200 for the xbee

Sorry I thought you were running radios from ArduSimple. You will probably have to double check the configuration on your radios and make sure that they match. Also double check the baud rate on your base and make sure in matches that of the radios.

1 Like

Yeah I bought everything through Mouser, Ardusimple has a lot of their products but not the radios. Would the simplest thing to do to be to swap in both XBees at the base station and change the baud rate to 115200 on each of them then use the firmware you linked above for the Teensy? Or should I (is it possible to) change the baud rate for the base station (I assume on the Sepentrio web interface)? Also is there an advantage to one rate or the other?

Okay an updated, to the saga after adjusting the baud rate on the simpleRTK3b (wasn’t hard to find how to change it), the XBee radios and the Teensy firmware to match (both at 9600 and 115200) I broke down and just bought a new pair of XBee radios from Ardusimple. Got them plugged in and I’m getting correction to my board and everything is working like it should.

Time is money and sometimes the best solution to a problem is just throw some money at it.