RTKBase: a GUI for your own Gnss Base Station

The method outlined by @Stefal should allow this as both services A and B run concurrently. I have ‘A’ sending to one rtk2go mount point and ‘B’ sending different messages to another.

I have not updated to the latest release but my understanding is that A and B are useful e.g. if one mountpoint was for dual constellation receivers with legacy RTCM messages (possibly also restricted BW) while the other mountpoint was for modern receivers (MSM messages).

These seem to use the same base station coordinates while the recent request was to have independent coordinates. My question would be why two base coordinates as the SW works from one base receiver anyway?

In a shell…

ps -ef|grep str2str

You’ll see the format of the command - then, do “nohup str2str etc etc etc” and start as many as your PI can handle (I had 4 going on an RPI 2B quite happily).

My pi ran forever, so I wasn’t worried about having to manually restart it if not.


That’s exactly how I have mine set up at the moment (so I could play around with one for the AGI-3). Why someone would want differing coordinates for the same receiver I really don’t know but that is what he wanted for some purpose.

1 Like

Any idea why rtk2go might say “this stream is not parsed?” It used to show my antenna name, what messages I was sending, co-ordinates, etc.

I’m not sure exactly when this started happening. It definitely showed all the info before updating RTKBase a few weeks ago, but I can’t say for sure that it stopped showing it right after the update. I don’t think I have done any base maintenance other than the RTKBase update between showing/not showing.

Use SNIP and connect the rtcm3 viewer direct to your local rtkbase, what does that look like ?

Try to change antenna to ADVNULLANTENNA

Working fine now. Could it be the large 1005 interval that made rtk2go give up?

The descriptor shouldn’t prevent parsing. I sent a dummy 1008 to rtk2go for nealy three years without an issue.

The stream I was using never received a “this is your final password” email from rtk2go. I think what happened is that the temporary password expired and I was being treated as an unregistered connection, and that’s what causes the no parsing.

I have a different stream with almost the same name that did receive the email, it parses fine.

I’m going to re-register the name that doesn’t work and try to get a password reply email.

Ah, just noticed the underscores.

Just considering neatening up my base now I’m happy with it. I assume it will work via UART rather than USB, with the appropriate messages being sent by the F9P board? (& 3v3 ioref)

I do realise the Ardusimple board UART is marked incorrectly.

UART is fine, just select the right com port in RTKBase.

My base runs a micro F9P over UART to a pi/RTKbase, I helped someone else setup a lite F9P over UART to RTKbase as well.

Getting the pi’s UART configured correctly can be challenging sometimes. It’s not an F9P thing, it’s a Pi thing. There’s inconsistent information online and differences between operating systems and Pi versions. But you’ll be able to get through it.

The “detect and upgrade” only works over USB. But you can still run the commands manually over ssh.

1 Like

Hello, today this happened with the base station, PPP disappears almost every second and then comes back, and AGopen doesn’t RTK FIX. What can happen ?

i wanna use an ardusimple f9p, what settings or config do I need for this to work with rtkbase

You plug the F9P in with USB and press the detect/configure button.

so rtkbase will config the f9p

The PPP indicator has no direct relationship with what you see in AgOpenGps, it’s only a symptom.
The problem is elsewhere, antenna cable ? gps jammer ? Usb cable ?

1 Like

Hello, Steffal it worked perfectly until now, today I noticed that this PPP is disappearing, and I thought that’s why I wouldn’t get a fixed rtk, RTK fix 1sec-DGPS 1sec- flot…
I thought it was due to PPP. I’ll go check the antenna cable.